locked
Visual Studio 2012: Extensions and Updates are always disabled RRS feed

  • Question

  • User-931283679 posted

    Clicking Tools > Extensions and Updates shows the extensions I have installed; but only those installed by default are enabled.  All those I have installed myself are automatically disabled, with the Enable button greyed out.

    How do I enable them?

    Friday, December 14, 2012 6:41 AM

Answers

  • User-931283679 posted

    I needed to allow "loading of per-user extensions": Tools > Options > Environment > Extensions and Updates > tick box marked "Load per user extensions ... ".

    http://blog.mastykarz.nl/installed-visual-studio-extension-doesnt-work/.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, December 14, 2012 6:59 AM

All replies

  • User-931283679 posted

    I needed to allow "loading of per-user extensions": Tools > Options > Environment > Extensions and Updates > tick box marked "Load per user extensions ... ".

    http://blog.mastykarz.nl/installed-visual-studio-extension-doesnt-work/.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, December 14, 2012 6:59 AM
  • User-166373564 posted

    Hi ed_ward_graham

    Glad that you've solved your problem by yourself and I come here to confirm and close the issue.

    Thank you for sharing your solutions and experience here, and welcome to post your question on this forum in your future programming.

    Kind regards

    Monday, December 17, 2012 8:38 PM
  • User151468730 posted

    Hi ed_ward_graham,

    In order to enable you Visual Studios 2012: Extentions and Updates, you can click the Enable loading of per user extensions in the Extension Manager or under Tools > Options > Environments > Extension Manager > Load per user extensions when running as administrator.

    I hope this is helpful.

    Best Wishes!

    Thursday, December 20, 2012 9:01 PM