locked
Dynamic Data Website Wizard Template operation on VS2008 x64 - BLinq Untrusted RRS feed

  • Question

  • User1892531517 posted

    I have installed the Dynamic Data template from 07/18 preview drop on my Vista Ultimate x64 machine, and all the other templates appear to be working fine, but when I attempt to run the DynData website Wizard template, I get an error  while the template is attempting to create the project.

     Error: this template attempted to load an untrusted component 'Microsoft.VisualStudio.Web.Blinq, Version 9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f711d50a3a'. For more information on this problem and how to enable this template, please see documentation on Customizing Project Templates

     Needless to say the docs don't help.  I have the Microsoft.VisualStudio.Web.Blinq.dll on my machine and I made sure to unblock the .zip file I downloaded before I unzipped it and ran the install, and I ran it as Administrator from an elevated prompt using the x64 sdk command line.  What can I do to give the Blinq.dll trusted status?

    Sunday, August 10, 2008 8:00 PM

All replies

  • User-330204900 posted

    I suspect this to be an installation issue as 64-bit install for the wizard has be in there for quite a few releases, have you tried the same thing either on an x86 PC of with the Northwind database?

    Monday, August 11, 2008 2:51 AM
  • User-330204900 posted

    I have installed the Dynamic Data template from 07/18 preview drop on my Vista Ultimate x64 machine,

    Sorry if this seems too obvious a question [:$] but you have installed Visual Studio 2008 SP1 Beta before the 07/18 preview drop?

    Monday, August 11, 2008 6:07 AM
  • User1892531517 posted

    ...but you have installed Visual Studio 2008 SP1 Beta ... 

    Darn!  And I tried so hard to make sure I had listed all of the usual suspects [:P]!

    Yes the SP1 Beta was installed first, I just forgot to include that in my "pre-op" list, but thanks for clarifying.

     

    MH

    Monday, August 11, 2008 1:44 PM
  • User1892531517 posted

    ... have you tried the same thing either on an x86 PC ... 

    Thank you for your reply.  Yes it works fine on my co-worker's x86 machine.  I agree with you and also suspect it is a installation issue; what I am hoping for is someone can give me the manual steps necessary to make sure the BLinq.dll is marked as trusted (after all if it can be done by an automated installation system, then it is possible to do it manually).

     I, unfortunately, have not been able to figure it out.

     MH

    Monday, August 11, 2008 1:48 PM
  • User-330204900 posted

    Well what you need is this:

    Visual Studio 2008 Service Pack Preparation Tool This remove the Bata 1

    Visual Studio 2008 SP1 (also includes .NET 3.5 SP1) This installs the release version [:D]

    Hope this helps [:D]

    Monday, August 11, 2008 3:43 PM
  • User1892531517 posted

    Whoops, I may have a problem, remember I am running an Vista x64 machine... and the link to the preparation tool is...  VS2008-PatchRemovalTool-x86.exe [:O].

     I'm searching for the x64 version, but not having any luck so-far.

    Monday, August 11, 2008 4:45 PM
  • User1892531517 posted

     Please ignore my previous reply, in searching for the x64 version of the prep tool, I came across the original link for this tool at http://code.msdn.microsoft.com/RemoveKB944899.  And I remember reading the inforamtion about it, that when I was preparing for the SP1 I HAD come across the need for the prep tool, had seen there was no x64 version and had followed the manual instructions as detailed on http://blogs.msdn.com/heaths/archive/2008/05/16/kb944899-should-be-removed-before-installing-visual-studio-2008-sp1.aspx

    So I did do the prep, I did run the .NET 3.5 SP1 and very carefully followed the installation instructions.  Still no go.

     I guess I still need the manual steps for making the BLinq.dll a trusted assembly [:(]

     MH

    Monday, August 11, 2008 4:54 PM
  • User-330204900 posted

    I guess I still need the manual steps for making the BLinq.dll a trusted assembly

    I've had a think and I suspect that the BLinq.dll is somthing installed by the runtime specifically for the wizard which is still in preview so you may be stuck untill a fix or workaround is released.

    I know this doesn't help much [:(]

    Hopefully you'll get an answer form the team soon [:D]

     

    Monday, August 11, 2008 5:17 PM
  • User-330204900 posted

    Hi I've just run through the prep tool and install of SP1 and Blink.dll is not on my machine now so I suspect my previous post was correct and that the Blink.dll is a part of the wizard an we will need a new install to put just the wizard on now that SP1 is RTW.

    Hope this helps [:D]

    Monday, August 11, 2008 5:50 PM
  • User-330204900 posted

    P.S. the seperate Wizard is available here

    [:D]

    Monday, August 11, 2008 6:01 PM
  • User-1069526884 posted

    Hello hintzen,

    I am currently investigating this issue but in the meantime, please check the following:
    1. Make sure you have VS 2008 SP1 RTM installed.  The 08/06 release of the dynamic data wizard and all future releases will NOT work on VS 2008 SP1 Beta1.  Also, just as a clarification, the .NET framework service pack is not enough, you will need the VS service pack specifically for the wizard to work properly.
    2. When you run the installer for 08/06 release of the wizard, please scroll up through the command window before closing it to make sure there are no messages indicating failure at any step.

    I will get back to you guys as soon as I know something more, so hold tight until then [:)]

    Monday, August 11, 2008 6:47 PM
  • User-1069526884 posted

    Hi hintzen,

    If running the installer again doesn't work for you, please try the following:
    1. Start a Visual Studio Command Prompt (be sure to right-click it and choose Run as Administrator)
    2. In the command prompt, navigate to the folder where you extracted the 08/06 release (or, if you deleted it, just download it again and re-extract it somewhere).
    3. Type in "sn -Vr Microsoft.VisualStudio.Web.Blinq.dll" and hit enter
    4. You should get a message starting with 'Verification Entry added for...'

    Please let me know if this doesn't work for you.  Thanks!

    Wednesday, August 13, 2008 2:03 PM
  • User-330204900 posted

    Hi there appears to be no link for the 08/06 release on CodePlex now [:(]

    Wednesday, August 13, 2008 2:52 PM