"No data for the given query" on dashboard, but query returns results when directly run in Analytics blade


  • I don't believe anything has changed, but since December, our dashboard no longer shows chart data in some (not all) of our Analytics dashboard panels.

    Instead, some of these <g class="gr_ gr_109 gr-alert gr_gramm gr_inline_cards gr_disable_anim_appear Grammar multiReplace" data-gr-id="109" id="109">show</g> the message: "No data for the given query". However, clicking on the icon "Open in Analytics Blade" results in the query executing and returning data as normal (second screenshot).

    Anyone know what's going on here?


    Sunday, January 6, 2019 8:49 PM

All replies

  • Thank you very much for bringing this to our attention. We've been able to reproduce something similar to what you have reported and are investigating it further.

    Tuesday, January 8, 2019 5:29 PM
  • Hi Steven_481,

    To help us troubleshoot the issue further, I would request you to change the tile configuration on the Dashboard to reflect data from last 30 days. This is how you can override the settings:

    1. Go to the Context Menu option represented by the three dots on the top right corner of the tile.

    2. Click on Customize tile data.

    3. Check Override the dashboard time settings at the tile level.

    4. Set the Timespan to Past 30 days.

    5. Click on Apply.

    Here is the screenshot depicting the steps:

    Please let us know what you see once the changes are applied. Thanks in advance!

    Friday, January 11, 2019 7:03 PM
  • Hello Steven_481,

    I checked with the appropriate Team, and was informed that this behavior of Azure Dashboard is by design.

    As one can see there are two time range filters when dealing with Analytics-related queries:

    • Dashboard Time Range Filter.
    • Query time range filter (if exists).
      for e.g a query that contains: | timestamp > ago(1d)

    By design, the Analytics part respects the period of time indicated by the Query time range filter that’s within the Dashboard time range.

    Hence, to get around this, you might want to try one of the following:

    • Choose a wider dashboard filter (but be aware that this would apply to all tiles on the dashboard).
    • Override the dashboard time range filter for that specific tile.
    • Running the query from the Analytics Blade (which you already are aware of).

    If none of these options help, and you feel that your requirement can benefit other Azure Users, please submit your suggestion here:

    Thank you once again for reaching out to us!

    Wednesday, January 16, 2019 4:45 PM
  • Hello Steven_481,

    Have you had a chance to check if the above worked for you?

    Thursday, January 24, 2019 7:10 AM
  • Hi BhargaviAnnadevara,

    Thank you for that information, the issue is resolved.

    The query requests data from a 30-day range, and customising the tile and applying a 30 day override works.

    Thursday, February 7, 2019 9:10 PM
  • Oh, glad it worked for you! Thanks for reaching out to us!
    Friday, February 8, 2019 2:57 AM