locked
Unable to debug RRS feed

  • Question

  • User-1496281956 posted

    I have an ASP.NET webPages website (WebPages 3) and I am using Visual Studio 2012 Pro. In ISS my website is setup and I want to use the IIS server for debugging in VS I changed the start options and set it to the following settings:

    "Don't open a page. Wait for a request from external application"

    "Use custom server" (asimpc:24)

    Debuggers

    ASP.NET, SQL Server

    I always get error "unable to debug"

    I am using VS as admin I have no idea why this happens, unless WebPages does not support this.

    Saturday, January 4, 2014 10:20 AM

All replies

  • User71929859 posted

    Open your project using visual studio and go to the properties of the project (By right clicking on it in the solution explorer). Then go to the Web tab. There you can select the IIS as the server. Now when you run the project, it will use IIS as the web server.

    Saturday, January 4, 2014 8:57 PM
  • User-1496281956 posted

    Open your project using visual studio and go to the properties of the project (By right clicking on it in the solution explorer). Then go to the Web tab. There you can select the IIS as the server. Now when you run the project, it will use IIS as the web server.

    When I do that VS tells me it will run on server localhost:65623 I want it to run on asimpc (this is the URL I configured it in IIS my self)

    Sunday, January 5, 2014 8:23 AM
  • User-1454326058 posted

    Hi Critical,

    I would like to know the details below:

    1. Is it the website project? (not the web application project)
    2. Could you debug the website project if you use the default web server?
    3. Are there any error message in the Event Viewer? Please provide if it has. (Right click my computer icon=>manager=>Event Viewer=>Windows logs=>Application)

    Please try to create a new project and try again.

    Thanks

    Best Regards

    Monday, January 6, 2014 2:40 AM
  • User-1496281956 posted

    Starain chen - MSFT

    Hi Critical,

    I would like to know the details below:

    1. Is it the website project? (not the web application project)
    2. Could you debug the website project if you use the default web server?
    3. Are there any error message in the Event Viewer? Please provide if it has. (Right click my computer icon=>manager=>Event Viewer=>Windows logs=>Application)

    Please try to create a new project and try again.

    Thanks

    Best Regards

    1. Yes

    2. Yes

    3. No

    I have created a new project does the same thing. I am using ASP.NET WebPages Framework.

    Monday, January 6, 2014 4:48 PM
  • User-1454326058 posted

    Hi Critical,

    What’s the Base URL value that you specified? Is the asimpc:24?

    If so, please try to add the http:// prefix.

    On the other hand, please refer to these link below to check something:

    # Unable to Start Debugging on the Web Server

    http://msdn.microsoft.com/en-us/library/dwesw3ee(v=vs.110).aspx

    BTW: I can debug webpages successfully as you said (With the custom server, don’t open …).

    Thanks

    Best Regards

    Monday, January 6, 2014 9:41 PM
  • User-1496281956 posted

    Hi Critical,

    What’s the Base URL value that you specified? Is the asimpc:24?

    If so, please try to add the http:// prefix.

    On the other hand, please refer to these link below to check something:

    # Unable to Start Debugging on the Web Server

    http://msdn.microsoft.com/en-us/library/dwesw3ee(v=vs.110).aspx

    BTW: I can debug webpages successfully as you said (With the custom server, don’t open …).

    Thanks

    Best Regards

    Hi,

    Completely forgot about this thread! Yes base URL is asimpc:24 and putting http:// makes not difference. I have looked at that URL attaching, I forgot to mention manually attaching does work, but I have to do this every time I wish to debug.

    Sunday, January 12, 2014 9:21 AM
  • User-1454326058 posted

    Hi Critical,

    Please share the project to me.

    About share the file in the SkyDrive, please refer to:

    http://windows.microsoft.com/en-us/skydrive/share-file-folder

    Thanks

    Best Regards  

    Monday, January 13, 2014 3:32 AM
  • User-1496281956 posted

    Starain chen - MSFT

    Hi Critical,

    Please share the project to me.

    About share the file in the SkyDrive, please refer to:

    http://windows.microsoft.com/en-us/skydrive/share-file-folder

    Thanks

    Best Regards  

    I couldn't really do that, for security and privacy reasons, hope you understand. Now I do have a intranet project and works 100% fine and I can debug, it's just with this one website I cannot. Both websites are in same drive, have same .Net and have permissions, one works otherone does not. 

    Does VS put a log any where of all errors occured? It just says "Unable to debug" A better error message would help, Event viewer has nothing.

    Monday, January 13, 2014 4:27 PM
  • User71929859 posted

    Yes base URL is asimpc:24

    Then you need to attach the worker process to visual studio in order to debug a website which is hosted in IIS. Please check the below articles. It willl help you on how to do that

    http://www.codeproject.com/Articles/37182/Debug-your-ASP-NET-Application-while-Hosted-on-IIS

    http://www.codeproject.com/Articles/38132/Remote-IIS-Debugging-Debug-your-ASP-NET-Applicatio

    Monday, January 13, 2014 5:17 PM
  • User-1454326058 posted

    Hi Critical,

    The Ruchira’s solution is the other way to debug. (Attach the process to the IIS)

    Please try it and tell us the result.

    Thanks

    Best Regards  

    Tuesday, January 14, 2014 1:48 AM
  • User-1496281956 posted

    CriticalError

    Yes base URL is asimpc:24

    Then you need to attach the worker process to visual studio in order to debug a website which is hosted in IIS. Please check the below articles. It willl help you on how to do that

    http://www.codeproject.com/Articles/37182/Debug-your-ASP-NET-Application-while-Hosted-on-IIS

    http://www.codeproject.com/Articles/38132/Remote-IIS-Debugging-Debug-your-ASP-NET-Applicatio

    I you sure that's not old school, that's for VS 2005, in the modern version you hit debug and it should automatically detect the processor it does it for one of my projects but not the other. I did say manually adding the proccess works, but hitting debug or F5 when the settings are put in the start options window does not work..

    Tuesday, January 14, 2014 5:18 PM
  • User71929859 posted

    CriticalError

    I you sure that's not old school, that's for VS 2005, in the modern version you hit debug and it should automatically detect the processor it does it for one of my projects but not the other. I did say manually adding the proccess works, but hitting debug or F5 when the settings are put in the start options window does not work..

    Debugging an already hosted website is different than debugging a website run from Visual Studio. I'm not sure that I understood what exactly you are trying to do. I'm in a mind that you are trying to debug a website which is already hosted in IIS. In that case, the only way you can debug is by attaching the worker process.

    If it's a visual studio project you are trying to debug with IIS, then as I said in my first reply, you can change the server to IIS so when you hit debug, it will run using IIS.

    Tuesday, January 14, 2014 5:56 PM
  • User-1496281956 posted

    Ruchira

    CriticalError

    I you sure that's not old school, that's for VS 2005, in the modern version you hit debug and it should automatically detect the processor it does it for one of my projects but not the other. I did say manually adding the proccess works, but hitting debug or F5 when the settings are put in the start options window does not work..

    Debugging an already hosted website is different than debugging a website run from Visual Studio. I'm not sure that I understood what exactly you are trying to do. I'm in a mind that you are trying to debug a website which is already hosted in IIS. In that case, the only way you can debug is by attaching the worker process.

    If it's a visual studio project you are trying to debug with IIS, then as I said in my first reply, you can change the server to IIS so when you hit debug, it will run using IIS.

    OK let me make this a little clear.

    My Spec is:

    IIS (Express) 7.5 On Windows 7 Ultimate 32Bit

    Visual Studio 2012 Pro

    Basically the site is on the U:\ drive, I have manually added it as a website in IIS and gave it the url asimpc (asimpc is default PC name). Application pool is set to 4.0 intergated and permissions have been granted to admins, me and IIS.

    In Visual Studio when I open the website I use the Visual Studio Development server. Then right click on the solution click > Property Pages > Start Options, it is set to:

    Don't Open a website ....

    Use custom server (then the URl at the top, PS I changed the URL to http://asimpc)

    debuggers: > ASP.NET

    If I used IIS Express server I don't get these options and it uses a URL localhost:500xxxx

    This works for one of my other websites and it automatically uses the wp3 proccess. But for the other one it gives error unable to debug.

    I hope this clears things up. OH I forgot to say everything is on the same PC, IIS website, and VS

    Wednesday, January 15, 2014 4:33 AM