locked
Visual Studio stops responding to mouse clicks RRS feed

  • Question

  • Hey everyone,

     

    Visual Studio 2010 Ultimate (version 10.0.40219.1 SP 1Rel) stops responding to mouse clicks several times a day.  It's only when I click on the code when it stops responding.  I can click on the toolbars, solution manager, or other programs and everything works fine. I've got all addons disabled or uninstalled so it can't be those.

     

    I'm running Windows server 2008 64bit (no service pack), and have a pretty beefy machine.

    What can I do to fix this problem?

     

    Thanks

     


    • Edited by allholy1 Tuesday, May 3, 2011 12:10 AM
    Friday, April 8, 2011 2:53 PM

All replies

  • Hi Allholy1,

     

    Thanks for yoru post.

    It seems to be an intellisense issue,

    you can try command

    devenv /resetuserdata

    devenv /safemode to run VS in safe mode in command prompt.

    To avoid extensions loaded.

    Hope my reply helps.


    Ziwei Chen [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by Victor_Chen Tuesday, April 12, 2011 7:19 AM
    • Unproposed as answer by allholy1 Tuesday, April 12, 2011 3:01 PM
    Monday, April 11, 2011 9:25 AM
  • Thanks for responding Ziwei,

     

    I did a uninstall, then reinstalled visual studio 2010.  Seems like things are working OK now, knock on wood.  Hopefully it stays like this.  It seems like others were having this issue too here:  http://social.msdn.microsoft.com/Forums/en-US/vseditor/thread/2fdbaa28-e5a3-43bd-8acf-2f8d4e42838a

     

    Thanks,

    Nick

    • Proposed as answer by Victor_Chen Tuesday, April 12, 2011 7:19 AM
    • Unproposed as answer by allholy1 Tuesday, April 12, 2011 3:01 PM
    Monday, April 11, 2011 3:53 PM
  • It's doing it again :(.  I have started it in safemode and reset user data as your suggestions above with no dice.   Anything else I can try?
    Tuesday, April 12, 2011 3:02 PM
  • I'm switching to Mono if I don't get this resolved soon......  It really hurts bad.
    Tuesday, April 12, 2011 9:23 PM
  • Hi Allholy,

    let's scope the issue.

    Is it happened when you click on a specific code file or every files?

    I suspect VS tries to visit a temp file or something costs lots of time leads freezing,

    or the file from remote server is checking by antivirus.

    could you please check which file VS is going to call when freezing via process Minitor?

    Looking forward to your reply.


    Ziwei Chen [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Wednesday, April 13, 2011 7:55 AM
  • Thanks for the reply Victor.  It happens with all files.  Next time it freezes up I'll fire up process monitor and see what file VS is locked on.  Several of my coworkers have this problem too.  One said updating our video drivers fixed this issue.  I will keep you updated.

     

    Thanks

    Wednesday, April 13, 2011 2:27 PM
  • Updating the video card helped some.  But it just happened again.  

    *  could you please check which file VS is going to call when freezing via process Minitor?

    There's so much going on with devenv.exe, its realy hard to track down the problem because so much is being displayed.  I'll continue trying.

    Wednesday, April 13, 2011 4:41 PM
  • If you want, email me and we can set up a time for you to remote into my machine and take a look?
    Wednesday, April 13, 2011 4:46 PM
  • It's still happening :(.  In process monitor, the following registry calls are placed when I move the mouse outside of the IDE and then move it back in and click.  This is exactly when VS stops responding:

     

    10:09:57.2289503 AM    devenv.exe    25536    RegOpenKey    HKLM\SOFTWARE\Wow6432Node\Microsoft\CTF\KnownClasses    NAME NOT FOUND    Desired Access: Read
    10:09:57.2294791 AM    devenv.exe    25536    RegOpenKey    HKLM\SOFTWARE\Wow6432Node\Microsoft\CTF\KnownClasses    NAME NOT FOUND    Desired Access: Read
    10:09:57.2382424 AM    devenv.exe    25536    RegOpenKey    HKLM\SOFTWARE\Wow6432Node\Microsoft\CTF\KnownClasses    NAME NOT FOUND    Desired Access: Read

     

    I am able to reproduce this consistently.  Please help me get this resolved.  This really makes it a struggle to work with Visual Studio throughout the day


    Thanks in advance
    Thursday, April 28, 2011 3:17 PM
  • I killed the AntiVirus so it can't be that... 


    I'm working on a Windows Server 2008 box (no release candidate).  Please, I could really use some help!!  Right now I can't interact with the top of all the panels.  In the solution explorer, I can click on items in the tree view, but I can't click the refresh button, show all files, or even close out of that panel.

    It gets really difficult when I do a "find all files".  I can't click on the name of the file to navigate to it.  I have to hit alt a few times, then click really quickly to give it some focus, then arrow to the file I want to open and hit enter.  It's a total pain!!





    Friday, April 29, 2011 3:33 PM
  • Looks like many of the developers in my company are having this problem.  We are gold members so I think we can reach out to actual Microsoft Support for this?
    Monday, May 2, 2011 8:43 PM
  • I had the same symptoms as you describe in your original post.

    I went to capitalize a "R" and hit shift+ctrl+R at the same time. That key combo = "Start/Stop Recording Macro" which made all my mouse clicks stop working within all code files in my solution. I was still able to do everything else in Visual Studio however.

    I stopped it by repressing the key combo. Hope you guys are just having a crazy situation that is coincidental to all of you :).

    • Proposed as answer by Matti_tat_tat Wednesday, March 14, 2012 6:29 PM
    Thursday, May 12, 2011 10:46 PM
  • You can try to delete .ncb file. That's intellisence database file. It has something wrong and deleting it may solve this problem.
    Thursday, May 19, 2011 9:51 AM
  • 10:09:57.2289503 AM    devenv.exe    25536    RegOpenKey    HKLM\SOFTWARE\Wow6432Node\Microsoft\CTF\KnownClasses    NAME NOT FOUND    Desired Access: Read

    I am having the same issue here, BI Studio for SSIS 2008 R2, Win 7, 64-bit.

    Thursday, May 17, 2012 6:18 PM