none
office 2010 interop deployed to machine with office 2013 RRS feed

  • Question

  • Hi,

    My development machine has Interop for office 2010  (version 14).  -- and Visual Studio 2010 Professional  When I deploy to a machine with office 2013 installed (interop version 15) it mostly works, but certain things fail.  Here is what I have experienced so far:

    Save throws an exception-- Critical

    seting SheetsInNewWorkbook throws an exception

    Can I install Interop version 15 on my development box?  or version 14 on the target?  How?

    Friday, May 22, 2015 1:39 PM

All replies

  • Hello Mark,

    It does't matter what PIA version you use on the machine with Office 2013 installed. 

    What code do you have now? Where and when do you run it? Could you be more specific?

    Friday, May 22, 2015 4:24 PM
  • seting SheetsInNewWorkbook throws an exception

    this is the error message, better to show you code , for all we can know what you are trying to do

    Sunday, May 24, 2015 5:29 PM
  • ​Hi Mark9638,

    As the reply from Eugene, it doesn't matter what PIA version you use on the machine with Office 2013 installed. For running solutions in different versions of Office, you could refer the link below:

    # Running Solutions in Different Versions of Microsoft Office

    https://msdn.microsoft.com/en-us/library/bb772080.aspx

    It would be helpful if you could share us more information like what Eugene and Jenma have asked. Based on the less information, we could not find the root cause. In my option, if you used the feature in Office 2010 which is removed in Office 2013, you will get an exception.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Wednesday, June 3, 2015 8:54 AM