locked
no "open file/project" dialog in VS2010 RTM ? RRS feed

  • Question

  • (cross posting into this forum, the other forum is being closed apparently)

    hi there

    when i select

    • "File->Open->Project/Solution..." or
    • "File->Open->File..." or
    • "theme -> customize -> import" 

    does not display a file open dialog box. The toolbar button for the equivalent action also does not do anything. The IDE window will flash breifly as if it is opening the dialog, but then goes back to normal (under windows Aero, with dual monitor)

    however, if i change it to windows 7 basic theme, the same thing will happens, but there are different error dialog pop up at each of above:

    • "the operation could not be completed. ClassFactory cannot supply requested class"
    • "Creating an instance of the COM component with CLSID {DC1C5A9C-E88A-4dde-A5A1-60F82A20AEF7} from the IClassFactory failed due to the following error: 8004011"

    however the open file dialog seems to work fine in any other applications (including VS2008)... any idea ?

    thanks in advance

    Tuesday, April 13, 2010 10:35 PM

Answers

All replies

  • Hi Jojo665,

    Thank you for your post.

    Some clarification with you:
    Which edition of Visual Studio 2010 are you running now?

    As a try, could you please help me to try the points mentioned here: http://social.msdn.microsoft.com/Forums/en-US/vssetup/thread/0376db8f-4761-4ae5-9af2-98c53216318a#VS_IDE_unexpected_problems to eliminate some possible cause of your concern?

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, April 15, 2010 11:39 AM
    • Marked as answer by jojo665 Sunday, April 18, 2010 6:48 PM
    Sunday, April 18, 2010 6:48 PM
  • This problem suddenly cropped up for me on one machine. I tracked down the problem to App Compatibility settings for devenv.exe. It appears that Windows made an automatic adjustment to the compatibility settings for devenv.exe - I don't know why. But that's what caused the problem.

    In my case, the fix was as follows:

    1. In Windows Explorer, go to the folder C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE.

    2. Right-click the file devenv.exe, and choose Properties. Go to the Compatibility tab.

    3. Clear all the checkboxes. (In my case, the "disable visual themes" and "disable desktop composition" checkboxes had somehow gotten turned on.)

    4. Click Apply.

    5. If you have permission, click "Change settings for all users" and again make sure all the checkboxes are cleared.

    6. Click OK (twice) to close the Properties dialogs.

    Note: I am running Windows 7 on a 32-bit machine, with Aero completely disabled (via System | Advanced | Performance Settings | Visual Effects | turned off "Use visual styles on windows and buttons").

    Monday, March 5, 2012 7:48 AM
  • This was suddenly happening in VS2008/Win7 and I spent hours trying to work it out.. Thanks so much!! :D
    Saturday, July 25, 2020 1:04 PM