locked
Why can't I deploy my report? RRS feed

  • Question

  • Hello,

    I am a beginner and have just finished my first report. Now I want to deploy it but run into problems. The first problem was an error message when I right-clicked the report and choose 'Deploy'. I got the error message: "The specified TargetServerURL is not valid. Specify a valid URL for a report server in the deployment settings."

    In Solution Explorer I then clicked on the properties for the report and entered http://sc00srvapp011r1/ in the field 'TargetServerURL'

    When I tried again I got the error message "The specified report server URL http://sc00srvapp011r1/ could not be found. Verify the syntax of the URL and that the report server exists."

    I have created this server win2008R2/SQL 2008 and installed and configured it so that everything should run locally. My report works really good in preview mode.

    When I try to deploy, the Output window shows:

    ------ Build started: Project: Test report, Configuration: Debug ------
    Skipping 'Report1.rdl'. Item is up to date.
    Build complete -- 0 errors, 0 warnings
    ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

    Any help would be deeply appreciated...

    Friday, June 17, 2011 8:38 AM

Answers

  • In Solution Explorer I then clicked on the properties for the report and entered http://sc00srvapp011r1/ in the field 'TargetServerURL'


     

    Hello,

    You have to enter the URL of the reporting service, not only the server url =>

    http://sc00srvapp011r1/reportserver

    If you open this URL in Internet Explorer you should get a page from SSRS.


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing
    • Proposed as answer by Rakesh M J Friday, June 17, 2011 8:49 AM
    • Marked as answer by Elvis Long Tuesday, June 21, 2011 10:29 AM
    Friday, June 17, 2011 8:46 AM
  • Success!

    I changed the credentials for the Data Source and now the report it displayes correctly.

    thanks to everyone that helped out!

    Friday, June 17, 2011 1:51 PM

All replies

  • In Solution Explorer I then clicked on the properties for the report and entered http://sc00srvapp011r1/ in the field 'TargetServerURL'


     

    Hello,

    You have to enter the URL of the reporting service, not only the server url =>

    http://sc00srvapp011r1/reportserver

    If you open this URL in Internet Explorer you should get a page from SSRS.


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing
    • Proposed as answer by Rakesh M J Friday, June 17, 2011 8:49 AM
    • Marked as answer by Elvis Long Tuesday, June 21, 2011 10:29 AM
    Friday, June 17, 2011 8:46 AM
  • Great! Thanks a lot. That took me a little bit further, and now I get the error message "The permissions granted to user 'EMEA\zscx1org01' are insufficent for this operation" when I try to deploy the report.

    This user is in the group Administrators, so I thought that should be enough?

    Friday, June 17, 2011 9:42 AM
  • This user is in the group Administrators, so I thought that should be enough?


    No, the user (you) have to be member of System Administrator group in SSRS; the security are separate from Windows permissions.

    Logon to the server where SSRS is running, start the Internet Explorer explicit with "Run as Administrator" and then open the URL http://sc00srvapp011r1/reports (not /reportserver as before). On top right side there is a link "Side-Settings", navigate to it; there you have at left side a link "Security settings". Here you can add you account to role "SystemAdministrator". Afterwards it should work to deploy a report.


    Olaf Helper
    * cogito ergo sum * errare humanum est * quote erat demonstrandum *
    Wenn ich denke, ist das ein Fehler und das beweise ich täglich
    Blog Xing
    Friday, June 17, 2011 10:22 AM
  • Just as you suspected, my user was not part of the SystemAdministrator group. I added this user (EMEA\zscx1org01), but then when I tried to deploy again I still got the same message. The Output window shows:

    Build complete -- 0 errors, 0 warnings
    ------ Deploy started: Project: Test report, Configuration: Debug ------
    Deploying to http://sc00srvapp011r1/reportserver
    Error rsAccessDenied : The permissions granted to user 'EMEA\zscx1org01' are insufficient for performing this operation.
    Deploy complete -- 1 errors, 0 warnings
    ========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========


    • Edited by SPEHE Friday, June 17, 2011 11:27 AM spelling error
    Friday, June 17, 2011 11:09 AM
  • Hi SPEHE,

    1.Go to ReportManager.<<http://sc00srvapp011r1/reports>>

    2.SiteSettings-->Security -->Add your Credetials in BUILTIN\Administrators.


    Rakesh M J

    Dont forget to mark it as Answered if found useful

    MCTS,MCITP,MCSS

    http://mycubeandreports.blogspot.com/


    Friday, June 17, 2011 11:51 AM
  • Hello Rakesh and thank you for wanting to help me out.

    I managed to figure out that I also needed to add Content manager rights to the user. After deploying the Datasource, Datasets and report and then, when I go to \\sc00srvapp011r1\reports I will get three directories (Datasources, Datasets and 'Test report'). I then click on 'Test report' and then on Report1 which is the name on my report.

     

    When I do this from the server the report will display correctly, but when I do the same from my workstation i get the error message:

    An error has occurred during report processing. (rsProcessingAborted)
    
      The execution failed for the shared data set 'DataSet1'. (rsDataSetExecutionError)
        Cannot create a connection to data source ' Data source for shared dataset'. (rsErrorOpeningConnection)
          For more information about this error navigate to the report server on the local server machine, or enable remote errors
    I have no idea what these error messages mean....
    Friday, June 17, 2011 12:11 PM
  • can you please let us know the connectionstring that you are using in the datasource ?

    Please check the checkbox "Impersonate user" in the security properties.

    Thanks,

    Suman

    Friday, June 17, 2011 12:18 PM
  • Connection string: Data Source=scsql01;Initial Catalog=STIHL-SC-NF-EU2-DTA001

    Where do I find the 'Impersonate user'? I am not sure what security properies you mean...?
    • Proposed as answer by Suman Sarkar Wednesday, April 24, 2013 10:04 AM
    Friday, June 17, 2011 12:26 PM
  • Success!

    I changed the credentials for the Data Source and now the report it displayes correctly.

    thanks to everyone that helped out!

    Friday, June 17, 2011 1:51 PM