locked
PDB image issue in Visual Studio 2012 RRS feed

  • Question

  • User1258887660 posted

    I am having custom pdb file doesn’t match image issue thus unable to deploy web application successfully. How can I solve it? I have delete the bin folder/ clean the build and then rebuild several times but the error still exist. Once again, I tried to manually navigate the symbol path but fail.

    PDB issue

    Wednesday, September 28, 2016 2:34 AM

All replies

  • User-2057865890 posted

    Hi Birdy,

    It seems the issue is that the debugger was unable to find a valid PDB files for your modules. PDB files are matched against binary images using two parameters: identifier (GUID) and age. There is more information about this process in this article.

    reference:

    http://stackoverflow.com/a/20501086 

    http://stackoverflow.com/questions/7749558/pdb-does-not-match-image-error 

    Best Regards,

    Chris

    Thursday, September 29, 2016 7:12 AM
  • User1258887660 posted

    Hi Chris, 

    Thanks for your reply.

    Symbol not found error is solved. But I was not able to give dummy value to getUserInfo. Screenshot is attached. Does that mean PDB file still having issue? If so, how can I fix it? 

    Thursday, September 29, 2016 7:57 AM
  • User-2057865890 posted

    Hi Birdy,

    Does that mean PDB file still having issue?

    Not clear. The screenshot seems ok. Could you add watch to userIdentity and userId?

    Best Regards,

    Chris

    Thursday, October 6, 2016 5:52 AM