locked
Unexplained error indicator after "Make into User Control" RRS feed

  • Question

  • I'm trying out my first prototype using Sketchflow, and followed a couple tutorials.  I assembled several "Basic TextBox - Sketch" assets into a stack to simulate a Navigation sidebar, added text and background color to them, and then encircled them all to select them and clicked "Make into User Control" so I could add them to all my pages.

    Now I'm left with blank box containing the area I encircled, and a mustard yellow exclamation point in the upper left corner, which I assume means there is something wrong, but there is absolutely no indication of what.  How do I find out what I did wrong?
    Tuesday, October 13, 2009 3:17 PM

All replies

  • try a rebuild. usually this happens when you make a user control, or changes to a user control. you have to build/rebuild to update the changes
    Tuesday, October 13, 2009 3:33 PM
  • Well, I tried that, and the box outline disappeared completely.

    I just looked into the xaml file for the user control, and it looks to be basically empty.  Where did all my work go? Do I have to start all over and redo it?

    Color me very frustrated!
    Tuesday, October 13, 2009 3:46 PM
  • restarting blend sometimes helps with strange errors too
    Tuesday, October 13, 2009 3:55 PM
  • Well, it appears my error was in converting it into a User Control instead of a User Component.  But why it made all my work completely disappear, I don't know.

    I ended up trashing the project and starting completely over.  At least it was a little easier the second time.  Still a steep learning curve.

    Whoops, it looks like I spoke too soon.  I just turned back to my project, and see that the exclamation point is back.  It wasn't there a few minutes ago, and I haven't touched the screen!

    Again, no explanation as to what the error is!
    Tuesday, October 13, 2009 4:26 PM
  • Hi Dave,

    As I understand, you are getting an exclamation point on the artboard. You should also see an yellow rectangle around your control (user component).

    The good news is that there is no error. The yellow rectangle means that you made some changes to your component and than you switched to a scene where that component is used without building the project. In that case, Expression Blend tries to show you a preview of your changes, but in some cases, that preview may not be 100% accurate. Once you build your project (Ctrl + Shift + B or Project -> Build from the main menu), Blend can instantiate your control directly (and the display is much more accurate), and it doesn't display that warning anymore.

    Hope this helps,
    Adrian
    • Proposed as answer by James Pack Sunday, April 27, 2014 3:18 AM
    Wednesday, October 14, 2009 12:58 AM
  • Hi Adrian, this is basically a more thorough version of what I previously stated, and he said that it did not work.
    Wednesday, October 14, 2009 12:37 PM
  • Dave,

    I am also just getting my hands dirty with this, and I am having a similar issue, however I did notice there is something you can do within the "Objects and Timeline" window.  In there, make sure that the control is visible.

    However, I can see my control but I can't move it.

    Cheers!
    Friday, October 30, 2009 11:14 AM
  • Ouch for a user interface tool, this is terrible design!

    Had the same problem.  Looked everywhere, than found this article.  Rebuild worked great, but don't warn me, without providing any feedback as to what is wrong.

    Thursday, February 4, 2010 6:43 PM