none
Disable Format on Copy in VS 2015

    Question

  • Hi,

    I'm loving VS 2015 and all, but there's this really frustrating feature where (when I have a block of code selected) and I copy it with 'Ctrl+C', it freezes up for a few seconds and then a dialog pops up saying that it's trying to format the selection on copy....

    This is really slow and irritating and I'd like to disable this feature as I don't need it.  How can I disable the format selection on copy feature?

    Thanks,

    Danrae

    Thursday, February 04, 2016 4:00 PM

Answers

  • The setting can be found in Tools menu, then Options, then Text Editor. It is called “Format on paste” and appears in different places depending on language.

    Thursday, February 04, 2016 5:55 PM
  • I found doing the following resolved the issue:

    1. Close Visual Studio.
    2. Go to the root directory of the solution (the directory where the <solution name>.sln file is located).
    3. There is a hidden folder called ".vs" which contains the following sub-folders: "<solution name>\v14". You may need to change Explorer's settings option to "Show hidden files, folders and drives" to see the hidden folder.
    4. Navigate into ".vs\<solution name>\v14".
    5. Inside the "v14" folder is a hidden file called ".suo".
    6. Delete the ".suo" file.

    The ".suo" file contains per-user solution-specific settings, including:

    • Which files are open and the viewing position in the file
    • Expanded nodes in the Solution Explorer
    • Opened Tool Windows and its Positions
    • User Tasks
    • Breakpoints
    • Start-up Project
    • Contents of the Watch window
    • Whether a project is loaded/unloaded
    • The file is also used by Visual Studio Addins (VSPackages) to persist information that are specific to that solution/user.

    When you open the solution again in Visual Studio, a new ".suo" file will automatically be created.

    I hope this helps!

    Monday, June 20, 2016 11:22 AM

All replies

  • The setting can be found in Tools menu, then Options, then Text Editor. It is called “Format on paste” and appears in different places depending on language.

    Thursday, February 04, 2016 5:55 PM
  • I have the same problem, I turn off Format and Paste  on C# and it's still doing this Why is this happening, way too much stuff is turn on by default in Visual studio ... what they need to do is turn everything off and let people chose what features they want.. there sales would go threw the roof..LOL  here is the post that I had posted before I found this..

    https://social.msdn.microsoft.com/Forums/en-US/e334f767-32a9-40e6-8765-d95647a80d21/copy-and-paste-vs-2015?forum=visualstudiogeneral

    There has got to be a way to is able this??

    Monday, March 07, 2016 2:28 AM
  • After extreme testing it seems to be a bug in VS 2015...
    Wednesday, March 09, 2016 8:55 PM
  • Does anyone know if this issue has been resolved?  I'm still seeing this after Update 2.  Almost every copy & paste hangs for a few seconds.  Extremely annoying.  Turning off "format on paste" did not resolve this issue.
    Friday, May 20, 2016 4:17 PM
  • Same prob,  not working with update 2
    Tuesday, May 31, 2016 2:49 PM
  • I found doing the following resolved the issue:

    1. Close Visual Studio.
    2. Go to the root directory of the solution (the directory where the <solution name>.sln file is located).
    3. There is a hidden folder called ".vs" which contains the following sub-folders: "<solution name>\v14". You may need to change Explorer's settings option to "Show hidden files, folders and drives" to see the hidden folder.
    4. Navigate into ".vs\<solution name>\v14".
    5. Inside the "v14" folder is a hidden file called ".suo".
    6. Delete the ".suo" file.

    The ".suo" file contains per-user solution-specific settings, including:

    • Which files are open and the viewing position in the file
    • Expanded nodes in the Solution Explorer
    • Opened Tool Windows and its Positions
    • User Tasks
    • Breakpoints
    • Start-up Project
    • Contents of the Watch window
    • Whether a project is loaded/unloaded
    • The file is also used by Visual Studio Addins (VSPackages) to persist information that are specific to that solution/user.

    When you open the solution again in Visual Studio, a new ".suo" file will automatically be created.

    I hope this helps!

    Monday, June 20, 2016 11:22 AM
  • Hi,

    Still the same problem

    Maybe they will fix it in update 3?

    Thanks,

    Kiril

    Sunday, June 26, 2016 8:31 AM
  • NOPE!

    Still broke in Update 3.

    And no turning off the Option in tools does not actually turn it off.  It just seems to display a checked option, and nothing else.


    This is my signature.

    Friday, July 29, 2016 9:31 PM
  • Hi Dan,

    I have encountered the same issue before. But now the issue doen't exist in my Visual Studio. It's so strange and I did not change anything.

    Also I have found a lot of people have the same issues. For this issue, I have logged this issue to the Microsoft Connect:

    https://connect.microsoft.com/VisualStudio/feedback/details/2999230

    You can vote it and add your comments.

    Best Regards,

    Lake Xiao

    Monday, August 01, 2016 7:27 AM
    Moderator
  • Unfortunately this did not help either :(
    • Proposed as answer by GowthamKumarn Friday, February 24, 2017 5:21 AM
    • Unproposed as answer by GowthamKumarn Friday, February 24, 2017 5:21 AM
    Thursday, February 23, 2017 1:37 PM
  • I tried update 3 still i am facing the same issue.
    Friday, February 24, 2017 5:21 AM
  • Please read the error description. It's on *copy* not. Paste. Touching that setting does nothing to help (at least for me) so this is not an answer.

    Having this intermittent myself, getting that popup i need to cancel all the time. It's a bug in VS, it shoud do *nothing* on copy, other than copy.

    Friday, April 21, 2017 11:21 AM