none
[PHP][Web Apps] Getting Request time out with my website in Azure RRS feed

  • Question

  • Hi There,

    When I try to access my site, I get the request timed out error. I have a wordpress site(in php) and mysql database. I am using ClearDB as a provider for MySQL. 

    WHen I look at the diagnostics in Azure, there isn't much information which can help me out with the error. My config files are perfectly fine as it is pointing to right database.

    Also, the site works locally perfectly fine. I also can connect to MySQL (in Azure) without any issues.

    On another browser this is the message I am getting:

    • Error Code 10061: Connection refused
    • Background:The server you are attempting to access has refused the connection with the gateway. This usually results from trying to connect to a service that is inactive on the server.

    I have tried this in few different computer under different network.

    Any help in this is highly appreciated.

    Regards,

    Aggy




    Monday, November 23, 2015 12:59 AM

Answers

All replies

  • Hello MSSAGGY

    We would like to look into this further, I request you to share the following information:

    a. Name of the website, please share the name of the webapp following the instructions in the link below:
    https://github.com/projectkudu/kudu/wiki/Reporting-your-site-name-without-posting-it-publicly
    b. Exact time stamp when you stop the webapp from the portal and get the status as Unknown in UTC.

    Thanks,
    Syed Irfan Hussain

    Monday, November 23, 2015 2:27 PM
  • Hello Aggy,

    What port are you listening on? Is that port unblocked in your windows firewall?

    What binding is this? Can you connect to the port using IE (assuming you have an HTTP GET metadata enabled)?

    Regards,

    Dipin Mathew.

    Monday, November 23, 2015 6:41 PM
  • Hi Syed,

    Thanks a lot for your help. 

    I am using the trial version of azure before I can convince my organisation that Azure is the way to go. i just have 9 days left of the free trial. Hence, I am trying to post any issues I face on a daily basis. I am having roadblock on every stage.

    I have created the dummySite: dummyaggy.azurewebsites.net

    my real site starts with "t".

    I tried it in all the browser and having the same issue. The above is the error via a developer tools in Chrome:

    GET xxx.azurewebsites.net:39833/ net::ERR_CONNECTION_TIMED_OUT
    xxx.azurewebsites.net:39833/:1 GET xxx.azurewebsites.net:39833/ net::ERR_CONNECTION_TIMED_OUT
    xxx.azurewebsites.net:39833/:1 GET xxx.azurewebsites.net:39833/ net::ERR_CONNECTION_TIMED_OUT
    Failed to clear temp storage: It was determined that certain files are unsafe for access within a Web application, or that too many calls are being made on file resources. SecurityError
    xxx.azurewebsites.net:39833/:1 GET xxx.azurewebsites.net:39833/ net::ERR_CONNECTION_TIMED_OUT

    Regards,

    Aggy

    Tuesday, November 24, 2015 3:39 AM
  • Hi Dipin,

    Thanks a lot for your prompt response.

    I am using the trial version of azure before I can convince my organisation that Azure is the way to go. i just have 9 days left of the free trial. Hence, I am trying to post any issues I face on a daily basis. I am having roadblock on every stage.

    Azure have by default assigned port 39833 which is unblocked in my Firewall rule.

    I tried it it all the browser.

    Regards,

    Aggy

    Tuesday, November 24, 2015 3:42 AM
  • Hi Syed,

    Any Update?

    Regards,

    Agresh

    Saturday, November 28, 2015 6:17 AM
  • Hello MSSAGGY,

    I suggest that you stop and restart your webapp, and check if you have the same issue.

    Thanks,
    Syed Irfan Hussain

    Sunday, November 29, 2015 11:27 AM
  • It might be an issue with the server where the site is on and some bad connection with the cleardb database.

    I suggest your restart the Azure website holding the WordPress site. 


    Rami Sarieddine Technical Evangelist

    Sunday, November 29, 2015 12:14 PM
  • According your error issue: “GET xxx.azurewebsites.net:39833/ net::ERR_CONNECTION_TIMED_OUT

    xxx.azurewebsites.net:39833/:1”, it seems you visit your site via a custom port 39833, however, Azure Web Apps only allowed 80 and 443 port in inbound rules, and will block any requests via other ports. You can check the settings in “web.config” file in the root directory of your site whether there are any settings will change the port of your site.

    Or you can refer to https://azure.microsoft.com/en-us/blog/remote-administration-of-windows-azure-websites-using-iis-manager/ to check your site settings via IIS Manager.

    Otherwise, you can refer to https://azure.microsoft.com/en-us/documentation/articles/web-sites-php-web-site-gallery/ to create a new WordPress site to check whether the issue is still exists.

    Monday, November 30, 2015 4:01 AM
    Moderator