locked
SSRS 2017 configuration RRS feed

  • Question

  • I tried to add another option to export report in CSV but replace coma(,) with pipe (|) delimiter. My report server 2017. I modified rsreportserver configuration file and added this code:

            <Extension Name="Pipe" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering"/>
                <OverrideNames>
                    <Name Language="en-US">Pipe</Name>
                </OverrideNames>
                <Configuration>
                    <DeviceInfo>
                        <Encoding>ASCII</Encoding>
                        <FieldDelimiter>&vert;</FieldDelimiter>
                        <UseFormattedValues>False</UseFormattedValues>
                        <NoHeader>False</NoHeader>
                        <FileExtension>csv</FileExtension>
                    </DeviceInfo>
                </Configuration>
            </Extension>

    After the server stop working.

    Any help will be appreciated.

    Thank you

    Friday, April 19, 2019 4:09 PM

Answers

  • Hi Konstantin,

    As I observed, my opinion, it seems the code for "|" should be changed to "&#124;".

    My code is like 

         <Extension Name="Pipe" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering">
            <OverrideNames>    
              <Name Language="en-US">Pipe</Name>    
            </OverrideNames>   
            <Configuration>
              <DeviceInfo>
                <Encoding>ASCII</Encoding>
                <FieldDelimiter>&#124;</FieldDelimiter>
              </DeviceInfo>
            </Configuration>
          </Extension>

    Not sure, what you mean, that you server stop working. Did you mean after you copy and save your code to rsreportserver.config it stops work?

    Could you delete your code and paste mine for test?

    My test result sees below:

    Hope this helps.

    Regards,

    Lukas


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Konstantin007 Monday, April 22, 2019 6:26 PM
    Monday, April 22, 2019 3:30 AM

All replies

  • just change render format to csv in ssrs report for information check folllowing link.

    https://docs.centrify.com/en/css/2018-html/index.html#page/Reporting/Creating_the_Report_Subscription_for_CSV_Export.10.html


    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Friday, April 19, 2019 8:34 PM
  • I tried to add another option to export report in CSV but replace coma(,) with pipe (|) delimiter. My report server 2017. I modified rsreportserver configuration file and added this code:

            <Extension Name="Pipe" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering"/>
                <OverrideNames>
                    <Name Language="en-US">Pipe</Name>
                </OverrideNames>
                <Configuration>
                    <DeviceInfo>
                        <Encoding>ASCII</Encoding>
                        <FieldDelimiter>&vert;</FieldDelimiter>
                        <UseFormattedValues>False</UseFormattedValues>
                        <NoHeader>False</NoHeader>
                        <FileExtension>csv</FileExtension>
                    </DeviceInfo>
                </Configuration>
            </Extension>

    After the server stop working. 

    The XML config is not well-formed because the first Extension tag was closed. Also, SSRS want's a literal instead of entity reference for the delimiter. Try this version:

            <Extension Name="Pipe" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering">
                <OverrideNames>
                    <Name Language="en-US">Pipe</Name>
                </OverrideNames>
                <Configuration>
                    <DeviceInfo>
                        <Encoding>ASCII</Encoding>
                        <FieldDelimiter>|</FieldDelimiter>
                        <UseFormattedValues>False</UseFormattedValues>
                        <NoHeader>False</NoHeader>
                        <FileExtension>csv</FileExtension>
                    </DeviceInfo>
                </Configuration>
            </Extension>


    Dan Guzman, Data Platform MVP, http://www.dbdelta.com

    Saturday, April 20, 2019 12:54 PM
  • Hi Konstantin,

    As I observed, my opinion, it seems the code for "|" should be changed to "&#124;".

    My code is like 

         <Extension Name="Pipe" Type="Microsoft.ReportingServices.Rendering.DataRenderer.CsvReport,Microsoft.ReportingServices.DataRendering">
            <OverrideNames>    
              <Name Language="en-US">Pipe</Name>    
            </OverrideNames>   
            <Configuration>
              <DeviceInfo>
                <Encoding>ASCII</Encoding>
                <FieldDelimiter>&#124;</FieldDelimiter>
              </DeviceInfo>
            </Configuration>
          </Extension>

    Not sure, what you mean, that you server stop working. Did you mean after you copy and save your code to rsreportserver.config it stops work?

    Could you delete your code and paste mine for test?

    My test result sees below:

    Hope this helps.

    Regards,

    Lukas


    MSDN Community Support Please remember to click Mark as Answer; the responses that resolved your issue, and to click Unmark as Answer if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Konstantin007 Monday, April 22, 2019 6:26 PM
    Monday, April 22, 2019 3:30 AM
  • Hi Lukas !!!!

    Thank you for all your help. Your code working Fantastic. 

    Konstantin

    Monday, April 22, 2019 6:26 PM