none
WPR Error 0x8004e001 when saving boot trace RRS feed

  • Question

  • Client:

    Windows 7 SP1 x64
    WPR 6.3.9600.16384 (from the 8.1 ADK)

    Problem:

    Enabled a boot trace, enabled first level triage, cpu usage, disk i/o activity, and rebooted.  Logged into Windows, waited for WPR to launch and then when it was part way through saving the trace, it stopped with the error 0x8004e001.   Neither err.exe or winerr.exe appears to have this.  The trace file was not saved.  D:\ partition has ~12GB free.

    Wednesday, November 27, 2013 6:56 PM

Answers

  • With the help of a PFE, I was able to resolve this problem.  

    On Windows 7 SP1, there can only be 1 “NT Kernel Logger” “Event Trace Session” (ETS). Since I had Sysinternals Process Explorer running (which uses NT Kernel Logger ETS), it was preventing WPR from using the ETS.  Once procexp was closed, WPR was able to successfully record a trace. 

    • Marked as answer by BSOD2600 Sunday, July 13, 2014 2:29 AM
    Sunday, July 13, 2014 2:29 AM

All replies

  • Even with the recently released WPT v5.1.0 (from ADK/SDK 8.1), I still get this error message for a boot trace.   

    Thoughts on the root cause? 

    Friday, July 11, 2014 11:01 PM
  • With the help of a PFE, I was able to resolve this problem.  

    On Windows 7 SP1, there can only be 1 “NT Kernel Logger” “Event Trace Session” (ETS). Since I had Sysinternals Process Explorer running (which uses NT Kernel Logger ETS), it was preventing WPR from using the ETS.  Once procexp was closed, WPR was able to successfully record a trace. 

    • Marked as answer by BSOD2600 Sunday, July 13, 2014 2:29 AM
    Sunday, July 13, 2014 2:29 AM