none
Can't Create New Excel Project Visual Studio 2013 Office Tools The Project Cannot Be Created RRS feed

  • Question

  • I am having this issue on two computers. If I try to create an Excel 2013 Workbook C# in new projects, and choose create a new workbook, it starts to open Excel, and then I get this error in VS

    I have tried:

    1. Uninstall & Reinstall of VSTO from the Visual Studio Installer
    2. Uninstall & Reinstall of Visual Studio 2013 Ultimate, (manually removing anything with visual studio that was left over)
    3. Manually turning on the add-on Visual Studio Tools for Office Design-Time Adapter for Excel
    4. Installing VSTO by hand
    5. Enabling Macros
    6. Running VS as administrator
    7. Uninstalling & Reinstalling Office 2013 Pro Plus OLP

    I have made this change to excel:


    Like I said, this problem occurs on TWO pc's.  I have tried 2013 Visual Studio R1 and R2.  Does anyone have any ideas?

    Edit 3-1-2015

    There is still no answer to this, I have tried target frameworks:

    • 4.0
    • 4.5
    • 4.51

    And Running as Administrator.  Recently I upgraded to the CTP of Visual Studio 2015 Ultimate and the same problem exists.


    • Moved by zkandy Thursday, May 22, 2014 1:47 AM more related
    • Edited by JJStellato Sunday, March 1, 2015 8:48 PM
    Wednesday, May 21, 2014 2:09 AM

All replies

  • Hi JJStellato,

    As your issue is more related to VSTO, I would move it to the VSTO forum:
    http://social.msdn.microsoft.com/Forums/en-US/home?forum=vsto
    Thanks for your understanding.

    Wind Zhang
    TechNet Community Support

    Thursday, May 22, 2014 1:46 AM
  • Hello,

    What edition of Visual Studio 2013 do you have installed on the PC? Note, VSTO doesn't support the Express edition of the IDE.

    Did you install the latest updates for Visual Studio and Office on the problematic PC?

    What file path did you specify in the Create New Project wizard in Visual Studio?

    Thursday, May 22, 2014 7:56 AM
  • I have 2 computers experiencing the same issue. The primary computer is visual studio 2013 ultimate update 2. However I tried it on update 1 and the same problem existed. The vsto was both the inbox version from update one and I tried the may 2014 update to vsto. I have tried creating the project in C:\projects as well as c:\users\joe\documents\visual studio\projects In case you were wondering I am using office 2013 pro plus volume license.
    Saturday, May 24, 2014 5:21 PM
  • Hi JJStellato,

    Going by the comments so far I am under the impression that you have the following development environment.

    Visual Studio 2013

    Office 2013

    Can you also confirm target framework for the project being created ?

    Regards

    Sangeeth


    Sangeeth,MSFT

    Tuesday, May 27, 2014 1:56 AM
  • I have tried Target Frameworks:

    • 4.0
    • 4.5
    • 4.51

    All result in the same "The Project Cannot Be Created" error

    Tuesday, May 27, 2014 2:22 AM
  • Do you run Visual Studio as an administrator?
    Tuesday, May 27, 2014 8:35 AM
  • Yes, I have tried it running as administrator.  I get the same result on both PC's

    Tuesday, May 27, 2014 12:17 PM
  • Do you have any antivirus software installed on the PC?
    Tuesday, May 27, 2014 2:08 PM
  • There is no antivirus installed.
    Tuesday, May 27, 2014 2:21 PM
  • Thanks for the reply.

    The issue is not reproducible for me and I can confirm this not a known issue. We might need to do deeper troubleshooting at the repro machines.

    Because of its complexity your question falls into the paid support category which requires a more in-depth level of support.  If the support engineer determines that the issue is the result of a bug the service request will be a no-charge case and you won't be charged. Please visit the below link to see the various paid support options that are available to better meet your needs. http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone


    Sangeeth,MSFT

    Tuesday, May 27, 2014 8:57 PM
  • Hi, I have the exact same problem and message. I am using VSTO Professional 2013 and Excel 2013 with pretty much the same settings.
    Thursday, February 12, 2015 8:40 PM
  • It has been since may, I have upgraded through 2013 - 2014 and now the latest release 2015 and it's still not fixed.  It seems ever since I upgraded to a pre release of VS 2013 update is when it started, but I can't be sure, whatever update was pre release in May of 2014.  It's a very frustrating situation, but let's face it, they want us developing the web apps for office, not document level add-ins.

    Thursday, February 12, 2015 9:06 PM
  • Hi all,

    I just completed reinstalling everything and I now works fine. I uninstalled every MS Office software I had Excel 2013, and MS Project 2013 and Visual Studio 2013 Pro.

    I re-dowloaded MS Project 2013 Professional, MS Office Excel 2013 and Visual Studio 2013 Professional and re-installed in this same order. I rebooted after each installation to be on the safe side. It took some time but it works fine now. I was successfully  able to create an ExcelWorkBook Project in Visual Studio.

    Hope this helps.


    Thursday, February 12, 2015 11:21 PM
  • Hi all,

    are there more options for solving this problem?

    I tried out all possibilities, with no result. (Reinstall OS, Office, Visual Studio, VSTO, start VS as Admin).

    I use Visual Studio Community 2013 Update 4, VSTO Update 1 and Office 2013 Professional, Windows 8.1.

    I get the errormessage "Cannot create Projekt. Excel Workbook is damaged or missing.", when i want to create an document based Excel Project. 

    Has anybody an idea?

    best regards
    Chris

    (I hope my english is not to bad ;) )


    Sunday, March 1, 2015 12:44 PM
  • Hello Chris,

    Have you installed VSTO tools?


    Sunday, March 1, 2015 1:20 PM
  • Hi Eugene,

    yes, i installed VSTO. Creating a Word-Document via Visual Studio or Excel AddIn works fine.

    I also followed the instructions from link:https://msdn.microsoft.com/en-us/library/bb386131.aspx?f=255&MSPPError=-2147217396

    best regards

    chris

    Sunday, March 1, 2015 7:34 PM
  • You're probably not going to end up with a real answer from here.  Microsoft is in the process of bailing on the Desktop versions of Office, and only focused on the re-write of 365 leaving us behind.  I'm fairly certain a reload of Windows would solve the issue, but it's just not worth it, I'll just continue to code in VBA.

    Sunday, March 1, 2015 8:49 PM
  • Hi Chris, it works fine for me now although I did have a couple of mishaps and scares since I am working with this. It appears that the integration between Visual Studio and Workbooks is not that stable. I some times see the Properties (lower right corner) window competely diapearing for any and all controls I am working on. But all in all it works. Here is a screenshot of what it looks like when it works. Also I noticed that it takes some time to load Excel and if you change the Workbook directly this will cause some error.

    

    Sunday, March 1, 2015 9:15 PM
  • Hi,

    this Problem was solved by apos22

    https://social.msdn.microsoft.com/Forums/de-DE/e2285cc0-c638-4189-8d5d-eadd3ce6cbda/visual-studio-community-2013-und-vsto-excelarbeitsmappe-kann-nicht-erstellt-werden?forum=vstode (german)

    or

    http://stackoverflow.com/questions/13695526/why-cant-i-create-an-excel-vsto-workbook-project-in-visual-studio-2010/29037321#29037321 (english)

    Thanks a lot, apos22!

    Tuesday, March 17, 2015 6:49 AM
  • remove the Office update:

    security update for Microsoft office 2013 KB3115153


    Friday, March 31, 2017 1:16 PM