locked
I can Never Get the php msi.exe to work RRS feed

  • Question

  • User-1836896639 posted

    I installed php using the wpi and that went fine then i  installed the joomla throught the wpi too  next i download the 5.3.1 msi and then went to add remove and uninstalled the 5.2.11 then i installed the 5.3.1 now when i go to locolhost/joomla i get this error

     

    HTTP Error 500.0 - Internal Server Error

    The page cannot be displayed because an internal server error has occurred.

     

    <FIELDSET><LEGEND>Detailed Error Information</LEGEND>
    Module FastCgiModule
    Notification ExecuteRequestHandler
    Handler PHP_via_FastCGI
    Error Code 0x00000000
    Requested URL http://localhost:80/Joomla/index.php
    Physical Path C:\inetpub\wwwroot\Joomla\index.php
    Logon Method Anonymous
    Logon User Anonymous
    </FIELDSET>
    <FIELDSET><LEGEND>Most likely causes:</LEGEND>
    • IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
    • IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
    • IIS was not able to process configuration for the Web site or application.
    • The authenticated user does not have permission to use this DLL.
    • The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.
    </FIELDSET>
    <FIELDSET><LEGEND>Things you can try:</LEGEND>
    • Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
    • Check the event logs to see if any additional information was logged.
    • Verify the permissions for the DLL.
    • Install the .NET Extensibility feature if the request is mapped to a managed handler.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click
    </FIELDSET>

    so i do not know how to fix this but if i do it manualy i can get it to work

    Sunday, December 13, 2009 11:03 AM

Answers

  • User-1405480850 posted

    Problem fixed and PhpMyAdmin is working perfectly well. The reason for the problem was both PHP and Windows 7.

    The 'hosts' file present in Windows 7 at location "C:\Windows\System32\drivers\etc" has the line containing localhost commented. I am not part of Windows team but my feeling is that 'localhost' also gets resolved from DNS.

    And PHP MySQL driver was not able to connect to MySQL server with localhost getting resolved from DNS. I don't have any clue why.

    Solution was to edit the 'hosts' file and uncomment the line containing localhost. That's it and PhpMyAdmin was happy and connected.

    And by the way, though the problem involved Windows 7 as well as PHP, I do not think that the solution lies in WINDOWS7. Because replacing PHP5.3.1 with PHP5.2.11 makes phpMyAdmin work perfectly without any changes to the 'hosts' file. This is something which should be looked by PHP MySQL driver team.

    Thanks Howman for working patiently on this and allowing me to connect to your machine.

    Don.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, December 15, 2009 5:06 PM

All replies

  • User-1405480850 posted

    Hi,

    Joomla at least for me has compatibility problem with PHP 5.3.1. Please first try Joomla with PHP 5.2.11 which works for me perfectly.

    We need to hear completely from Joomla that they work completely on PHP5.3.1 before trying to move to PHP5.3.1.

    Thanks,

    Don.

    Sunday, December 13, 2009 12:03 PM
  • User-1836896639 posted

    Thats true but they fixed that in verion 1.5.15 which is offierd with wpi

    and that error also comes up with MyBB 1.4.10 which is compatable with php 5.3.1

    and if i do it manuly with php 5.3.1 it will work

     

    http://www.joomla.org/announcements/release-news/5249-joomla-1515-released.html

    Under

    System
    Fixed PHP 5.3 compatibility issues (17150)

    Sunday, December 13, 2009 12:18 PM
  • User-1405480850 posted

    Hi,

    Forget Joomla, is a simple PHP file working properly? I mean a simple file like:

    <?php
    phpinfo();
    ?>

    Does the above work?

    If PHP has been installed properly using the MSI, the binaries are exactly same and there should not be any difference in the functionality.

    Thanks,

    Don.

    Sunday, December 13, 2009 12:24 PM
  • User-1836896639 posted

    Yea the test php does work

    Sunday, December 13, 2009 12:52 PM
  • User-1405480850 posted

    Hi,

    So if I am correct, you are saying that the PHP binaries when installed from PHP MSI and the one installed from Zip file are behaving differently. I hope you are consistent using either TS/NTS as well as VC6/VC9 binaries for both the installation. This means if you have use PHP5.3.1 VC9 NTS MSI, you are comparing it with PHP 5.3.1 VC9 NTS Zip file instllation and you are getting different results. This is highly unlikely. However if this is the case I would like you to file bug at http://bugs.php.net against the PHP installer code.

    Thanks,

    Don.

    Sunday, December 13, 2009 12:59 PM
  • User-1405480850 posted

    Hi,

    One more thing to keep and eye on. Ensure that extensions loaded using both the methods are same. I mean same set of extensions should be loaded by both the installation. An extension difference might cause the above behaviour.

    Thanks,

    Don.

    Sunday, December 13, 2009 1:01 PM
  • User-1836896639 posted

    yea i have tryed this before because i think the webpi install would be easyer but the msi install has never worked for me not once the only differnce when i use the zip is i put it in C:\php where as with the msi i just use the defult C:\Program Files (x86)\PHP\ 

    php-5.3.1-nts-Win32-VC9-x86.msi  25,802 kb thats the msi i installed

    php-5.3.1-nts-Win32-VC9-x86.zip 14,406 and the zip i used

     

     

    Sunday, December 13, 2009 1:10 PM
  • User-1405480850 posted

    Hi,

    See WPI just invokes the PHP MSI with bunch of arguments which by default installs some popular PHP extension. And WPI supports PHP5.2.11 for now. The way you moved to PHP5.3 is also okay as it is the easiest way. And you mentioned that a simple PHPINFO page is working. This means PHP is working from IIS point of view as well as functionality wise. I am deeply worried why Joomla didn't work. Whereas the same Joomla worked switching to zip file installation.

    It would be good if you can find the root cause of this problem. You can try installing zip file to another location C:\PHP1 and see if that works again. It will be advantageous to know the root cause and if the problem exists in MSI let's fix it.

    BTW, I just installed Joomla on my WIN7 box using WPI and moved to PHP5.3.1 using the MSI and everything works as expected. So I am at least not seeing any problem.

    Thanks,

    Don.

    Sunday, December 13, 2009 1:46 PM
  • User-1836896639 posted

     What am i doing wrong that i can not do this on my computer

    can you tell me what permissions should be  i just tryed phpMyadmin i can get to logon screen the i put password and logon in and click ok then i get the same error

    Sunday, December 13, 2009 1:52 PM
  • User-1405480850 posted

    Hi,

    If you are using 5.3.1 try switching to 5.2.11 version of PHP and see. I have phpMyAdmin running and I don't see any problem login in.

    Thanks,

    Don.

    Sunday, December 13, 2009 1:56 PM
  • User-1836896639 posted

    so i do not mess this up add/remove php 5.3.1 then go to webpi and install 5.2.11 or download it from php download page

    Sunday, December 13, 2009 1:59 PM
  • User-1405480850 posted

    Just download PHP5.2.11 from http://php.net, uninstall PHP5.3.1 and instal PHP5.2.1. No WPI involved. Ensure that after installation a simple PHPINFO page is working.

    You should not get 500 on phpMyAdmin using PHP 5.2.11. At least I didn't. It will be also good if after uninstalling PHP5.3.1 you delete the PHP.INI file if you don't need it.At least ensure that C:\Program Files\PHP folder is empty.

    Thanks,

    Don.

    Sunday, December 13, 2009 2:06 PM
  • User-1836896639 posted

    So that worked what am i doing wrong trying to go from 5.2.11 to 5.3.1 i know  joomla works and mybb and phpmyadmin work with 5.3.1 but why can i not do it using msi

    Sunday, December 13, 2009 2:17 PM
  • User-1836896639 posted

    I did notice one thing that the 5.2.11 i got from php.net was V6 but it say to use V9 with IIS

    Sunday, December 13, 2009 2:27 PM
  • User-1405480850 posted

    Hi,

    You do not have VC9 builds for PHP5.2 which is fine. VC6 or VC9 doesn't matter. You can again use MSI to go from 5.2 to 5.3 and see if this works. Start with a simple PHPINFO page before testing the applications.

    I am for sure I can use phpMyAdmin with PHP5.3.1 with MSI installer.

    Thanks,

    Don.

    Sunday, December 13, 2009 2:39 PM
  • User-1836896639 posted

    so i should remove the 5.2.11 add/remove then install the 5.3.1 msi V9

    Sunday, December 13, 2009 2:41 PM
  • User-1405480850 posted

    Yes.

    Thanks,

    Don.

    Sunday, December 13, 2009 2:44 PM
  • User-1836896639 posted

    i got to restart now brb

    Sunday, December 13, 2009 2:51 PM
  • User-1836896639 posted

    Same error

    Error Summary

    HTTP Error 500.0 - Internal Server Error

    The page cannot be displayed because an internal server error has occurred.

     

    <FIELDSET><LEGEND>Detailed Error Information</LEGEND>
    Module FastCgiModule
    Notification ExecuteRequestHandler
    Handler PHP_via_FastCGI
    Error Code 0x00000000
    Requested URL http://localhost:80/Joomla/index.php
    Physical Path C:\inetpub\wwwroot\Joomla\index.php
    Logon Method Anonymous
    Logon User Anonymous
    </FIELDSET>
    <FIELDSET><LEGEND>Most likely causes:</LEGEND>
    • IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
    • IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
    • IIS was not able to process configuration for the Web site or application.
    • The authenticated user does not have permission to use this DLL.
    • The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.
    </FIELDSET>
    <FIELDSET><LEGEND>Things you can try:</LEGEND>
    • Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
    • Check the event logs to see if any additional information was logged.
    • Verify the permissions for the DLL.
    • Install the .NET Extensibility feature if the request is mapped to a managed handler.
    • Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click
    </FIELDSET>
    Sunday, December 13, 2009 3:04 PM
  • User-1405480850 posted

    Can you run php-cgi from command line? I mean php-cgi.exe -v.

    And if a simple PHPINFO page works, this means the application has some problem.

    Thanks,

    Don.

    Sunday, December 13, 2009 3:13 PM
  • User-1836896639 posted

    I guess the Msi install is not for me cause i just can not get it to go i will just have to stick with the manul zip

    But i do get differnt error from phpMyAmin

    phpMyAdmin - Error

    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

    Went to command prompt and  C:\Users\Laptop>php-cgi -v

    and i got this

    php-cgi.exe - System Error

    The Program Can't start because gmodule-2.dll is missing from your computer. Try reinstalling the program to fix this problem.

    then i click ok

    php-cgi.exe - System Error

    The Program Can't start because OCI.dll is missing from your computer. Try reinstalling the program to fix this problem. X3

     

    Sunday, December 13, 2009 3:27 PM
  • User-1405480850 posted

    OK, I can understand the problem now. So it seems some extension is causing this. You can get rid of this by start commenting out extension line in the PHP.INI file until you get rid of all the errors and try phpMyAdmin page again. You know commenting extension means finding all the lines starting with 'extension=' line in PHP.INI file and comment it by starting the line with ';'.

    Otherwise just stick to other type of installation or use 5.2.11 version of PHP.

    Thanks,

    Don.

    Sunday, December 13, 2009 3:43 PM
  • User-1836896639 posted

    yea i re ran the php5.3.1 and undid thoes extenions now no errors when running php-cgi -v 

    but the errors in joomla still stand and phpmyadmin still showing

    phpMyAdmin - Error

    Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

    Sunday, December 13, 2009 3:52 PM
  • User-1405480850 posted

    This means there are still some more errors. If you have configured PHP to log errors, please see the log file. If you have used the MSI and hasn't chnaged anything, the log file should be in all probability present at C:\WINDOWS\Temp\php-errors.txt or something. See what errors are there in the log.

    Thanks,

    Don.

    Sunday, December 13, 2009 6:38 PM
  • User-1405480850 posted

    Howman,

    I didn't get your email id in the private message. Please create a Remote Desktop Session and send me the credentials.

    Thanks,

    Don.

    Tuesday, December 15, 2009 3:19 PM
  • User-1405480850 posted

    Problem fixed and PhpMyAdmin is working perfectly well. The reason for the problem was both PHP and Windows 7.

    The 'hosts' file present in Windows 7 at location "C:\Windows\System32\drivers\etc" has the line containing localhost commented. I am not part of Windows team but my feeling is that 'localhost' also gets resolved from DNS.

    And PHP MySQL driver was not able to connect to MySQL server with localhost getting resolved from DNS. I don't have any clue why.

    Solution was to edit the 'hosts' file and uncomment the line containing localhost. That's it and PhpMyAdmin was happy and connected.

    And by the way, though the problem involved Windows 7 as well as PHP, I do not think that the solution lies in WINDOWS7. Because replacing PHP5.3.1 with PHP5.2.11 makes phpMyAdmin work perfectly without any changes to the 'hosts' file. This is something which should be looked by PHP MySQL driver team.

    Thanks Howman for working patiently on this and allowing me to connect to your machine.

    Don.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Tuesday, December 15, 2009 5:06 PM
  • User1995925070 posted

    Wow, that simple eh?  if this is a known issue, why isn't it more publicly available?

     idk, but it works great now.  Thank!

    Sunday, February 7, 2010 1:22 PM
  • User1091935805 posted

    Hi guys

    I was trying to solve this problem from about 5 hours!

    The solution was incredible simple. In config.inc.php I just change "localhost" by "127.0.0.1". It's working fine now!

     Thanks for your help!

    Omar Ramon
    Lima - Peru

    Thursday, February 11, 2010 11:48 PM
  • User-1405480850 posted

    Hi,

    Yes that is also a way because when you specify actual IP address, name resolution will not happen and connection will go through. However be aware that this solution will work only for the particular application (in this case phpMyAdmin). If you install another application like Drupal it will show a similar problem. So a global solution is to disable IPV6 in your host file.

    Thanks,

    Don.

    Friday, February 12, 2010 12:05 AM
  • User-1120461109 posted

     I have done everything that I can find on the web to get phpmyadmin to let me enter mysql database, but keep running into #2002 will not connect. For the life of me I just really don't know what to do now. I am running ii7 with windows server 2008.

    Friday, February 11, 2011 9:46 AM
  • User-1672167363 posted

    Hello @ zombiesskull2001,

    Please take a look at the "manipulating the MySQL grant tables"

      MySQL Server information here http://dev.mysql.com/doc/refman/5.5/en/adding-users.html 

    You need to use mysql  to allow users to logon to the mysql server & databases.

    The default  strict security  settings are to deny access to mysql;

    You can get by with doing the minimal steps in the article.

    After you allow the root user to access the localhost server much of your problems should be resolved.

    If your not confortable with using the command prompt:

    You canoptionally  download & install the MySQL Work Bench and use it to do many of the other

    tasks necessary to use Mysql Server.

    Martin :)

    Friday, February 11, 2011 1:58 PM
  • User-1672167363 posted

    Hello,

    There is a good guide for phpmyadmin after you fix mysql server access.

    at the IIS Aid site here http://www.iis-aid.com/articles/how_to_guides/install_and_configure_phpmyadmin_iis?page=0%2C1 

    Martin :)

    Friday, February 11, 2011 2:00 PM