locked
Access 2013 "You do not have exclusive access to the database..." RRS feed

  • Question

  • I have a database that is shared by multiple people in our office. In fact, there are multiple database files used this way.

    Recently, when a second person opens one of these files they get the "You do not have exclusive access to the database at this time. If you proceed to make changes, you may not be able to save them later." information box popping up. It actually pops up 15 times before the users can get into the file.

    This is the only file that is doing this and never did it in the past. Any idea what may be causing this?

    Wednesday, June 11, 2014 7:44 PM

Answers

  • >>Locking files all look fine to me. 3 people have the file open right now, 3 locking files.<<

    ???

    If 3 or any number of users run the database at the same time, there should only be ONE locking file, not 3. 

    What are the names of the locking files if there are 3 locking files related to this particular database.

     

    OTOH, you really should split the database into Front-End and Back-End...

     


    Van Dinh

    • Marked as answer by George Hua Thursday, June 19, 2014 8:59 AM
    Thursday, June 12, 2014 12:27 AM
  • Good Morning Jason,

    We try our best to answer your questions as they are presented to us without having access to your machine(s).

    I'd like to return to an earlier point in this thread where I mentioned

    "Since this is a shared database you need to ensure that the settings are not set to open exclusive. In A2013 File / Client Settings / Advanced / Default Open Mode = Shared."

    Your response was

    "Default Open Mode is Shared. If one person had theirs not set to Shared, wouldn't this only happen if they were the first to open this file?"

    Not exactly. This is a setting on each computer not on the database. If the second user has this setting then when no one is in the database it should open normally for them and not allow other users to open it giving them a message that the file is locked by another user, it may list their name.

    However the error, "You do not have exclusive access to the database at this time" is given when the Second user has exclusive selected and someone else is already in the database.

    The work around is to turn off the exclusive opening on the affected machine, not the database. The correct setup is to use a split database whenever you have multiple users from multiple PC's or logins.


    Chris Ward

    • Marked as answer by George Hua Thursday, June 19, 2014 9:01 AM
    Monday, June 16, 2014 4:40 PM

All replies

  • Since this is a shared database you need to ensure that the settings are not set to open exclusive. In A2013 File / Client Settings / Advanced / Default Open Mode = Shared.

    If it is already set this way then check for locking files (.laccdb) with the same name as what you are trying to open. Sometimes if someone shutdown there computer improperly ( or there was a power outage ) then the locking file may be stuck and need deleting.

    As a side note: consider splitting your application and giving each user their own copy, this will prevent this from happening.


    Chris Ward

    Wednesday, June 11, 2014 7:58 PM
  • Default Open Mode is Shared. If one person had theirs not set to Shared, wouldn't this only happen if they were the first to open this file?

    Locking files all look fine to me. 3 people have the file open right now, 3 locking files.

    I guess I have to look into splitting this file.

    Wednesday, June 11, 2014 9:03 PM
  • Is the second user trying to open an Object in design view when it happens?

    Do you have code that modifies objects while users are in the db?

    Are you using code to Save Records? This can cause the db to get locked for other users if you are using something like; DoCmd.Quit acQuitSaveAll

    This code is used to save design changes not Records. To save Records you would use something like; If Me.Dirty = True Then Me.Dirty = False


    Chris Ward

    Wednesday, June 11, 2014 9:24 PM
  • No, they are all opening straight into Form View. I'll get everyone out and double check.

    This is a very generic file to keep track of projects/priorities. I don't think there is any underlying code in it. But I'll check to make sure the design change save isn't in there somewhere.

    Wednesday, June 11, 2014 10:06 PM
  • >>Locking files all look fine to me. 3 people have the file open right now, 3 locking files.<<

    ???

    If 3 or any number of users run the database at the same time, there should only be ONE locking file, not 3. 

    What are the names of the locking files if there are 3 locking files related to this particular database.

     

    OTOH, you really should split the database into Front-End and Back-End...

     


    Van Dinh

    • Marked as answer by George Hua Thursday, June 19, 2014 8:59 AM
    Thursday, June 12, 2014 12:27 AM
  • Locking files all look fine to me. 3 people have the file open right now, 3 locking files.

    This is why I asked you to look here. As Van pointed out there should only be 1 locking file for a database unless you are using a replication database.

    PS...Splitting the database is very easy (unless you have a replication database). The Wizard will do this in a couple of seconds or you can do it yourself in a couple of minutes.

    The manual method is opening a new db, Import everything except the Tables from the 1st db. Then use the Link Tables Manager to link to the 1st db. A couple of things to keep in mind when splitting the db...

    1. Place the BE (back end) close to the root of the drive as the deeper into folders you go the slower the db connects.
    2. If placing your BE on a server then connect the FE (front end) using the UNC path rather than a mapped drive as this will slow it down also.
    3. Do not access the db through a wifi network.
    4. Encrypt the BE before you link to it from the FE to protect the data Tables from being accessed directly to prevent data corruption.
    5. Use the same name for the BE as the FE and add to it _be so you know which BE goes with which FE. Example; Access.accdb & Access_be.accdb

    Hth


    Chris Ward

    Thursday, June 12, 2014 1:45 PM
  • Sorry about that. I answered that completely wrong. I was looking at the Computer Management open files on the server rather than the folder where it is located. There is only 1 locking file while the database is open.

    I guess I have to split the database. but that's not really answering why this happened. It's only a workaround.

    Monday, June 16, 2014 4:04 PM
  • Good Morning Jason,

    We try our best to answer your questions as they are presented to us without having access to your machine(s).

    I'd like to return to an earlier point in this thread where I mentioned

    "Since this is a shared database you need to ensure that the settings are not set to open exclusive. In A2013 File / Client Settings / Advanced / Default Open Mode = Shared."

    Your response was

    "Default Open Mode is Shared. If one person had theirs not set to Shared, wouldn't this only happen if they were the first to open this file?"

    Not exactly. This is a setting on each computer not on the database. If the second user has this setting then when no one is in the database it should open normally for them and not allow other users to open it giving them a message that the file is locked by another user, it may list their name.

    However the error, "You do not have exclusive access to the database at this time" is given when the Second user has exclusive selected and someone else is already in the database.

    The work around is to turn off the exclusive opening on the affected machine, not the database. The correct setup is to use a split database whenever you have multiple users from multiple PC's or logins.


    Chris Ward

    • Marked as answer by George Hua Thursday, June 19, 2014 9:01 AM
    Monday, June 16, 2014 4:40 PM