locked
VS11 XAML Designer - Can't add controls

    Question

  • Hi. When I load up VS11 Beta and open a project (or create a new one for that matter), and go into the designer view for the default page (or a page I create), I cannot add controls to it. If I try to add a control I get the following error:

    A reference to "Windows, Version=255.255.255.255, Culture=neutral, PublicKeyToken=null, ContentType=WindowsRuntime" has been added to the project, but you must build the project before you can use types from it.

    Building the project does not solve the problem. It appears that if I add the control via straight XAML it works fine.

    Is there a known solution to this? Searching for this issue did not bring up any results.

    Thursday, March 22, 2012 10:29 AM

All replies

  • Hi,

    Avian, couple of questions:

    1. Which project are you using? Is this a C++ / C# or a VB Metro project

    2. Are you creating default controls [ex: Button] or you are running into this issue with Custom Controls?

    If you can get in touch with me at navits at microsoft dot com, I can investigate this issue.

    -Navit Saxena

    Thursday, March 22, 2012 11:08 PM
  • I'm hitting this too.

    I'm using a blank VB Metro project and I'm using the standard controls, such as XAML button, textbox etc.  On placing any of these on the design surface I get this error. 

    Thanks


    David


    David Overton - work at Microsoft, here as myself (Author) of Windows Intune 2.0:Quickstart Administrators Guide http://davidoverton.com/windowsintune

    Sunday, April 1, 2012 9:23 AM
  • I have exactly the same problem... But i am using C# for a blank Metro project. What's wrong? Thx
    Tuesday, April 3, 2012 11:50 AM
  • I also have that problem with a VB Metro Style application.

    The application builds and run on a blank page, but I get that error message as soon as I try to draw any of the standard XAML controls on the page.

    It happens on a Dell portable that was running Windows 7 and that already had Visual Studio 10 Permium SP1 installed, along with both Office 2003 and Office 2007.

    I first upgraded it to Windows 8 Community Preview, and then Downloaded and installed the Visual Studio 11 Express pointed to from the Community Preview web page.

    The problem seems to come from the ToolBox, because controls can be manipulated in other ways.

    If I load an already developped project such as your XAML essential controls sample1, I can play with the controls, copy and paste them, but cannot add a new controls from the Toolbox.

    I can copy and paste controls from your sample application to a new one I created and can then work normally.

    Controls can be added manually by typing the necessary entry in the XAML tab of the page designer.

    But no way to work from the ToolBox.

    Thursday, April 5, 2012 1:45 AM
  • We are actively investigating this issue and will report back as soon as we have more details.

    -Navit Saxena

    Thursday, April 5, 2012 6:37 AM
  • I have the same problem with the Toolbox.
    Two observations.
    1) I can add/use the Pointer and RichTextColumn controls in application controls using simple drag&drop.
    2) Blend for VS has no idea where vs2011 solution projects are located.

    Regards

    Sunday, April 8, 2012 6:36 PM
  • I too am having exactly the same problem. I can't seem to be able to drop anything from the tool box onto the form. I'm receiving exactly the same error as the OP; any further news on this issue?
    Sunday, April 8, 2012 11:48 PM
  • I have the same problem.  My workaround so far has been to add controls manually to the xaml file, then I can edit them in the designer.
    Monday, April 9, 2012 1:15 PM
  • I had the problem on a VB Metro Style application in the Express Edition that is limited to Metro Style Development.

    I uninstalled it and installed the Professional Edition.

    The problem persists.

    Saturday, April 14, 2012 8:03 PM
  • I'm getting the same problem in vb2011 Metro Style. No way to add control from a tool box, same error message...

    MS please help...

    Friday, April 27, 2012 6:51 PM
  • I had a similar problem, but with Expression Blend 5 Beta, where I could not choose new Project types to add from or new Controls to add from. The problem was fixed for me (for Expression Blend) when I installed Visual Studio 11 Professional Beta. I think perhaps the Express Beta version was missing those things.
    Monday, April 30, 2012 6:04 PM
  • me too

    Jithu R Jacob

    Thursday, May 10, 2012 5:38 AM
  • Friday, May 11, 2012 10:37 AM
  • Hi All,

    Can you please try installing Windows8 Release Preview and Visual Studio 2012 RC builds. This issue should be fixed in this release.

    -Navit Saxena

    Thursday, May 31, 2012 8:40 PM
  • You mean download another 3 GB's ?????????????????????

    Jithu R Jacob My current Project : https://sourceforge.net/projects/harisree/files/Harisree/

    Tuesday, June 12, 2012 7:48 AM
  • You mean download another 3 GB's ?????????????????????

    Unfortunately yes, and since you can't upgrade Consumer Preview -> Release Preview, you have to reinstall all your apps as well.  It's a pain, but it took me less than a day, and now everything is working well.  While I was at it, I upgraded to the 64-bit version so I could take advantage of the extra RAM in my PC.

    VS2012 is a big improvement over VS2011, except that some of the APIs changed, so it broke my code.   :(   Looks like I'm going to lose another day getting the apps working again, but that's life on the bleeding edge.

    Tuesday, June 12, 2012 1:18 PM