none
Security settings for this service require 'Anonymous' Authentication but it is not enabled for the IIS application that hosts this service RRS feed

  • Question

  • Hi,

    I know this error has been discussed many a times but I couldn't find any answers relevant to me so am trying again.

    Basically, I have a WCF service, which I have deployed to on one of our servers and it works fine with Windows Authentication. However, when I move the same server to a different server, I get the following error 

    "Security settings for this service require 'Anonymous' Authentication but it is not enabled for the IIS application that hosts this service"

    I have checked the bindings and they seem to be configured fine. They are as below

            <bindings>
                <basicHttpBinding>
                    <binding name="basicHttpBindingConfig">
                        <security mode="TransportCredentialOnly">
                            <transport clientCredentialType="Windows"/>
                        </security>
                    </binding>
                </basicHttpBinding>
            </bindings>

    I have also compared the machine.config and applicationHost.config files on the two servers and they seem similar.

    Any pointers / help would be really appreciated.

    Regards,

    Hamid

    Friday, March 1, 2013 11:38 AM

Answers

  • Hi,

    My web service is not using the default website and didn't want to "Enable Authentication" on my website. 

    Resolved this problem by re-pairing .Net Framework 4.5. Not sure how that resulted in the above mentioned error but it did.

    As a background, I had to remove certain features from the IIS server and had to run aspnet_regiis -i on top of it to re-register ASP.Net. 

    I was getting the above mentioned error. Re-installing .Net Framework 4.5 fixed it.

    • Marked as answer by Hamid Shahid Friday, March 1, 2013 3:27 PM
    Friday, March 1, 2013 3:27 PM

All replies

  • In IIS you have to enable "Anonymous Authentication". Click on default website and then click on Authentication under IIS category.

    ViBi

    Friday, March 1, 2013 12:02 PM
  • Hi,

    My web service is not using the default website and didn't want to "Enable Authentication" on my website. 

    Resolved this problem by re-pairing .Net Framework 4.5. Not sure how that resulted in the above mentioned error but it did.

    As a background, I had to remove certain features from the IIS server and had to run aspnet_regiis -i on top of it to re-register ASP.Net. 

    I was getting the above mentioned error. Re-installing .Net Framework 4.5 fixed it.

    • Marked as answer by Hamid Shahid Friday, March 1, 2013 3:27 PM
    Friday, March 1, 2013 3:27 PM