none
ID displayed in combo box instead of text from the table RRS feed

  • Question

  • I have a table defined called "PPP_DB". Within that table I have a link to another table "Classification_List" that is used to limit the selection to this specific list.  I have another table "Notification_DB"  that uses the information from the "PPP_DB" table as a field. The problem is that the combo box both in the database view of the table and the associated form of the "Notification_DB" both display the ID from the "Classification_List" table instead of the value from the table. How do I fix this problem. The weird thing is if I create a query of the "PPP_DB" everything displays correctly.
    Wednesday, May 17, 2017 3:17 PM

All replies

  • Hi,

    Sounds like you're using lookup fields at the table level. If so, may I suggest you remove them and simply use queries as you know work and actually is the preferred way.

    Check out this article: The Evils of Lookup Fields in Tables

    Hope it helps...

    Wednesday, May 17, 2017 3:23 PM
  • Check the properties of the combo box. Right-click on the combo box and choose 'Properites'.

    Check the Row Source, Column Count, Column Widths and Bound Column properities.

    If your row source returns more than one column, ensure you have the Column count and the Column Widths property set up correctly to display the correct column. e.g. 0";0.5" will display the second column in the row source.



    Wednesday, May 17, 2017 4:13 PM
  • Hi ])ragon]v[aster,

    is your issue is solved?

    I find that you did not done any follow up after creating this thread.

    if you had find the solution for your issue by yourself then I suggest you to post it and mark it as an answer.

    if your issue is still exist then try to check the suggestions given by the community members that may solve your issue.

    you can try to update the status of this thread so that we can try to provide further suggestions if needed.

    if your issue is solved and you not need any further suggestion then mark this thread as an answer by posting your solution.

    then we can close this thread.

    if you do not mark the thread then we are not able to close this thread.

    as a result, thread will remain open.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, May 29, 2017 7:16 AM
    Moderator