locked
Crystal Reports XI R2, VS2005 and x64

    Question

  • I'm  using CR XI R2 and VS2005, when I load the report, it throw the following exception, it only occur on my  win2k3 server x64, but not on x86 windows. I've  installed CRRedistx64.msi under VS2005 folder, I don't know it is suitable for XI R2 or not. Does XI R2 support 64bit windows?

    Exception:
    An error has occurred while attempting to load the Crystal Reports runtime.

    Either the Crystal Reports registry key permissions are insufficient or the Crystal Reports runtime is not installed correctly.

    Please install the appropriate Crystal Reports redistributable (CRRedist*.msi) containing the correct version of the Crystal Reports runtime (x86, x64, or Itanium) required.  Please go to http://www.businessobjects.com/support for more information.

    Sunday, February 19, 2006 4:40 PM

Answers

  • no, the only 64 bit version of Crystal Reports is the version that came bundled with VS 2005 (CR 10.2).  Business Objects hasn't released any other information regarding x64 yet.
    Tuesday, February 21, 2006 12:04 AM

All replies

  • no, the only 64 bit version of Crystal Reports is the version that came bundled with VS 2005 (CR 10.2).  Business Objects hasn't released any other information regarding x64 yet.
    Tuesday, February 21, 2006 12:04 AM
  • Oh... CR came with VS2005 has many bugs and slow in performance, at least 3-5 times slower compared with R2. I've tested R2 with .Net on a 32bit windows, it fixed all problems I got with 10.2, but it is sad that it cannot support x64 platform.
    Wednesday, February 22, 2006 10:40 PM
  • Hi Barry,

    We found a way to get Crystal Reports XIR2 web pages to work on a x64 machine when using iis.  It is to set iis to use a 32 bit worker process, refer to Microsoft's knowledge base article http://support.microsoft.com/default.aspx?scid=kb;en-us;895976 

    Basically in a command prompt you have to type the following command to enable 32-bit Application Pools:

    cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 1

    Down the road, if you've made the required steps to update your stuff to 64-bit, type the following to re-enable 64-bit Application Pools:

    cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 0

    Friday, March 10, 2006 12:43 AM
  • Hey Mewdied

    i tried 

    cscript %SystemDrive%\inetpub\AdminScripts\adsutil.vbs set w3svc/AppPools/Enable32bitAppOnWin64 0

    this script on command prompt but it displays the error 
    Input Error:Can not find the script file "C:\inetpub\AdminScripts\adsutil.vbs


    pls help........

    Monday, October 19, 2009 5:32 AM