none
Problem with Ctrl + Right Clic and Pimphony RRS feed

  • Question

  • Problem with Ctrl + Right Clic for Pimphony<o:p></o:p>

     

    Hello everybody,<o:p></o:p>

    First time i post (and i'm french), so i hope i do it well.<o:p></o:p>

    For my company, i've developped a solution with visual studio express 2015 (Visual Basic). On my main frame, i have a textbox that displays the phone number of the inhabitant of an appartment or a house selected in a datagridview<o:p></o:p>

    The purpose is to make appointments with them.<o:p></o:p>

    To ease the work of our operators, we have installed 3 years ago, on each computer, a software called pimphony that is 'synchronized' with the physical phones on the desks.<o:p></o:p>

    This sowftare allows them to select a phone number anywhere on any software, and by doing 'Ctrl + Right clic' (or 'Shift + right clic' - Configuration parameter), Pimphony recognizes automatically the phone number and pastes it in its own interface, where the operator just has to clic on a button to make the call.<o:p></o:p>

    3 years ago, this worked on Excel/Word/Etc. as well as on the software i developped. A one point, it didn't work anymore on the software i developped but it's still working on Excel/Word/Etc. Impossible to know when, impossible to determine at wich version of my software this changed.<o:p></o:p>

    So now, when on my textbox i do "Ctrl + Right clic", it always shows some kind of standard context menu with (Cancel/Copy/Cut/Paste/Delete/Etc.)

    The thing is that if i re-install Pimphony, it will work, but only until restart of the computer.<o:p></o:p>

    Has any one an idea about what could cause that?<o:p></o:p>

    Thank you for your help!

    Wednesday, July 5, 2017 10:11 AM

All replies

  • Hello,

    You did well with your post, so no problems there.

    Unfortunately though, it sounds like the issue may lie with the Pimphony software.  Have you contacted the developer and explained the issue to them?  It is unlikely that there is anything in your VB application that can be changed other than perhaps trying a RichTextBox instead of the standard TextBox.  By default, the RichTextBox will not show a context menu on a right-click so perhaps that will allow their software to inject its own context menu.

    The change could be due to moving to a newer framework version or running your application on a newer version of Windows (it isn't stated which version of the .Net Framework you are targeting or which Windows Operating system(s)).

    You can try changing to a RichTextBox but if that does not help you will most likely need to get support from the developer of Pimphony.


    Reed Kimble - "When you do things right, people won't be sure you've done anything at all"

    Wednesday, July 5, 2017 3:06 PM
    Moderator
  • Hello Reed Kimble,

    Thanks for your reply, and sorry for my delay (I have so many other problems!!!).

    I'm going to try that tomorrow and let you know.

    Wednesday, July 19, 2017 5:08 PM
  • Hello again,

    So I tried it this morning with a RichTextBox and it still doesn't work.

    I'm going to try to contact the developer of Pimphony, it might be my best chance...

    I'll let you know!

    Thursday, July 20, 2017 7:10 AM
  • Hi Jorish123456,

    Have you solve your issue now? If yes, please share your solution here, it is beneficial to other community members.

    Thanks for your understanding.

    Best Regards,

    Cherry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, August 1, 2017 8:07 AM
    Moderator
  • In case it may help anyone, I finally found out the problem's cause.

    I discovered the problem appeared when I decided to execute the software as administrator.

    In this case windows restricts some interactions on users interface. Question of security i presume.

    Recently, I needed to allow the user to drag&drop onto a datagridview placed on my mainframe.

    This issue is a lot more documentated on the net.

    Both problems had the same cause...

    So : Problem solved

    • Proposed as answer by Cor Ligthert Friday, September 15, 2017 1:04 PM
    Friday, September 15, 2017 1:01 PM
  • Jorish,

    In this kind of cases you can mark your own reply as answer for the benefit of others who have the same problem. 

    Merci (as we say in Holland :-)



    Cor


    Friday, September 15, 2017 1:04 PM