none
Issue with Large EDI 834 File RRS feed

  • Question

  • Hi

    I am using Biztalk 2006 R2 to store the EDI 834 to DB.On the Receive Port,I am getting error like

    A message received by adapter "FILE" on receive location "Receive834XML" with URI "C:\BizTalk-834Membership\834-Receive\*.*" is suspended.

    Error details: The Messaging Engine encountered an error during the processing of one or more inbound messages.

    The size of the file is 34,427KB and about 102118 records in it.

    Thanks

    • Edited by Harbir Thursday, June 24, 2010 5:39 PM
    Wednesday, June 23, 2010 4:48 PM

Answers

  • Email john@secondstaredi.com.  He just had this issue with a huge file and resolved it -- unfortunately I don't know the specifics.    He will be happy to explain what he did.

    Regards,

     

     


    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    Thursday, June 24, 2010 5:27 PM

All replies

  • BizTalk does not like big files. I have ran into this in the past. The solution is to break the file in the inbound so that biztalk will break each message into single transactions. What happens is that the X12 file comes in and it is broken down into xml. That make the file huge and the system chokes. Therefore, to solve this, break the file down at the receive location and that will correct your problem.
    Please Indicate "Mark as Answer" if this Post has Answered the Question
    Thursday, June 24, 2010 12:14 PM
  •  

    Thanks for your reply Carlos. Do you have any reference to check how we can break EDI file to multiple files?

    Thursday, June 24, 2010 2:06 PM
  • Try with this,

    Go to party --> EDI properties --> X12 properties --> Party as interchange sender -- > Ack Generation and -->
    You will see one option in the end "Spilt Interchange as Transaction Sets" under Inbound Batch Processing option.

    Have you selected this option or any other option ??
    Selecting this should resolve this problem. Please let me know how it goes ??

    You can also refer below discussion.

    http://social.msdn.microsoft.com/Forums/en-US/biztalkediandas2/thread/202aa493-bc3d-4c32-82ea-31afff4d7523

     


    Best Regards, Vishnu
    Thursday, June 24, 2010 3:40 PM
  • Hi Thanks for the reply,I already have this option selected in EDI Prperties for parties.

    Thursday, June 24, 2010 3:54 PM
  • Email john@secondstaredi.com.  He just had this issue with a huge file and resolved it -- unfortunately I don't know the specifics.    He will be happy to explain what he did.

    Regards,

     

     


    Jim -- Pro Mapping in BizTalk 2009, Apress Books, March 23, 2009
    Thursday, June 24, 2010 5:27 PM