none
Fix for Office Word 2010 open as Read Only on WSS 3.0 document RRS feed

All replies

  • Hi Xlinkch,

    Thank you for posting.

    Please refer to this article to see whether this can resolve your problem:

    http://support.microsoft.com/kb/2018958

    The article involves that the problem could be that WebDAV is enabled on the server and provide the resolution about the problem.

    Hope this can help you and just feel free to follow up after you have tried.

    Best Regards,


    Bruce Song [MSFT]
    MSDN Community Support | Feedback to us
    Wednesday, February 1, 2012 6:57 AM
  • Hi,

    Currently my WSS 3.0 is running on Win2003 R2 Server, so the article involves for WebDAV is for Win2008 Server.

    So how do I check the WebDev setting for my Win2003 R2 Server?

    Why is my Office 2007 does not have problem to open the document for edit on WSS 3.0 but Office 2010 will open it in Read-Only?


    xlinkch
    Wednesday, February 1, 2012 7:19 AM
  • Hi Xlinkch,

    Actually, I am not farmiliar with WSS 3.0 and difficult to reproduce the issue on my side, I will help you involve others to help you. There might be some delay about the response. Appreciate your patience.

    As for disabling WebDev setting for Win2003 R2 Server, please see whether these articles can help you:

    http://forums.iis.net/t/1149348.aspx

    http://support.microsoft.com/kb/241520

    http://support.microsoft.com/kb/332060

    Best Regards,


    Bruce Song [MSFT]
    MSDN Community Support | Feedback to us
    Thursday, February 2, 2012 8:14 AM
  • Hi Xlinkch,

    Please check whether WebDAV publishing is enabled on Windows Server 2003 R2.    IIS | Web Server Extensions | WebDAV Publishing.    If the setting is enabled please change the setting do an IIS RESET and test the issue.
    Check the Root Site “/” Collection Existence (Application Management | Site Collection List – Choose the Web Application make sure “/” Root Site collection exist.   If it is not present create one and test the issue
    What is Client Operating System and Office 2010 Version?
    What Type of Authentication configured for the Web Application?
    How many Servers in the Farm, also please let us know whether Load Balancer is present
    If the Client Operating system is Vista and above, please apply the registry part mentioned in the article http://support.microsoft.com/kb/943280 and recycle the WebClient Service. 

    Thanks !!


    Regards,
    Manas Biswas
    Microsoft Online Community Support


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, February 8, 2012 3:48 AM
  • The Client Operating System is Windows 7. The Office 2010 is the professional version.

    So now user on Windows XP with Office 2007 does not have problem with opening the same document in WSS 3.0 to edit, but those user on Windows 7 with Office 2010 will open that document in WSS 3.0 as Read-only.

    Currently the WSS 3.0 is install on single Server only so no Load Balancer present.

    Therefore, any solution for this issue with Office 2010 on WSS 3.0 can be provided?


    xlinkch

    Thursday, February 9, 2012 7:38 AM
  • Thank you for the update.  From the details you provided I see the issue is noticed on Windows 7 / Office 2010 but below information will help us to better narrow down the issue.

    Verify WebClient Service is enabled on the Client Workstation – Right Click on computer | Manage | Services and Application | Services | WebClient – Make sure the Service is enabled and running.
    Apply the registry part mentioned in the article http://support.microsoft.com/kb/943280  and recycle the WebClient Service.  Test the Issue
    Please check whether WebDAV publishing is enabled on Windows Server 2003 R2.    IIS | Web Server Extensions | WebDAV Publishing.    If the setting is enabled please change the setting do an IIS RESET and test the issue.
    Check the Root Site “/” Collection Existence (Application Management | Site Collection List – Choose the Web Application make sure “/” Root Site collection exist.   If it is not present create one and test the issue
    What Type of Authentication configured for the Web Application?  (Central Admin | Application Management | Application Security | Authentication Provider | Choose the Web Application – Top Right | Select the Zone – Example: Default | Authentication Zone).
    Thanks,


    Regards,
    Manas Biswas
    Microsoft Online Community Support


    Please remember to click 'Mark as Answer' on the post that helps you or click 'Unmark as Answer' if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, February 10, 2012 3:16 PM