locked
Database Experimentation Assistant cannot replay against Azure SQL Managed Instance RRS feed

  • Question

  • I captured and replayed a set of XEvents trace files from my SQL VM. Everything worked well. However, I tried to replay the same traces against an Azure SQL Managed Instance and it constantly fails no matter what I try.

    The whole replay seems to start normally enough, and preprocesses all the trace files successfully, but when it tries to replay them, it finishes very quickly and ends up with 0% success.

    I checked the log file which DEA generates - ostress.log - and it's full of the following errors. What can I do to fix this? All this testing is costing quite a lot of money and I'm not sure how to get it working with the managed instance.

    I know that the user/password are correct. I'm able to connect using SSMS from the same machine where DEA is running. Also, if I use an incorrect user/password, the replay won't even start.

    07/09/19 17:24:15.654 [0x00001CD8] Arguments:
    07/09/19 17:24:15.654 [0x00001CD8] -E
    07/09/19 17:24:15.654 [0x00001CD8] -Stcp:sqlmitestmi.1111111111.database.windows.net,1433
    07/09/19 17:24:15.654 [0x00001CD8] -iE:\TRACE\PreProcessOutput\*.rml
    07/09/19 17:24:15.654 [0x00001CD8] -cC:\Program Files (x86)\Microsoft Corporation\Database Experimentation Assistant\Dependencies\ReplayConfig.ini
    07/09/19 17:24:15.654 [0x00001CD8] -oE:\TRACE\PreProcessOutput\ReplayOutput
    07/09/19 17:24:15.654 [0x00001CD8] -Usqladmin
    07/09/19 17:24:15.654 [0x00001CD8] -P********
    .
    .
    .
    .
    07/09/19 17:24:15.821 [0x00002234] WARNING: Ignoring the network library specified in the <CONNECT> node of file E:\TRACE\PreProcessOutput\SQL00080.rml, global sequence -1 because the server name specified on the command line also contains a prefix specifying a network library.  All subsequent occurrences of this message will be suppressed for all input files and connections.
    
    07/09/19 17:24:16.012 [0x00001FD4] Attempt to establish connection failed.  See the detailed errors that follow:
    
    07/09/19 17:24:16.012 [0x00001FD4] SQLState: 28000, Native Error: 18456
    [SQL Server]Login failed for user 'sqladmin'.
    
    07/09/19 17:24:16.012 [0x00001FD4] SQLState: IM006, Native Error: 0
    Packet size change not supported by server, default used
    
    07/09/19 17:24:16.012 [0x00001FD4] Input file: E:\TRACE\PreProcessOutput\SQL00108.rml
    
    07/09/19 17:24:16.012 [0x00001FD4] NOTE: If the target server is running SQL Server 2000 or older version and the connection failed with an error such as "Encryption not supported on SQL Server" then you must add -T146 to the command line parameters to be able to connect.  However, doing so will not encrypt data transmitted between the client and SQL Server unless you specifically configure it per the SQL Server documentation.



    • Edited by noamo48 Wednesday, July 10, 2019 1:53 PM
    Wednesday, July 10, 2019 1:53 AM

All replies

  • As indicated here: https://docs.microsoft.com/en-us/sql/dea/database-experimentation-assistant-replay-trace?view=sql-server-2017, Can you try running the trace on a exact replica of sql vm from which you captured the trace.

    "The trace file for the workload must be replayed twice: once on an environment with the same version of SQL Server that runs on production and again on an environment that has the upgrade target SQL Server version"

    W.r.t to the errors, looks like it notifies issue authentication issues to connect to SQL Server Managed Instance and Trace file size, looks like the default roll over size is 200 MB


    Wednesday, July 10, 2019 12:02 PM
  • yes I already did this...what does it have to do with the question I posed though? I was able to replay the capture with no issues on my SQL VM but cannot replay it against the managed instance.

    I should note that with the same settings, I'm able to run a capture against the managed instance. Only replay does not work.

    • Edited by noamo48 Wednesday, July 10, 2019 2:16 PM
    Wednesday, July 10, 2019 1:40 PM
  • ok, looks like i misread your question, I was under the impression that you captured the trace from SQL VM and trying to replay in SQL MI. let me try to replicate the scenario and get back with my findings.
    Thursday, July 11, 2019 12:48 AM
  • Hi Srihad, thanks for your help so far. Have you had a chance to test this yet? I still haven't been able to get it working.

    Anyone else from the Microsoft Azure SQL team available to troubleshoot this?

    Monday, July 15, 2019 2:29 PM
  • Hi Noamo,

    Can you please provide your instance name and Subscription ID by sending this to AzCommunity. We have no way to reproduce this with your specific environment. I need to escalate this.

    Regards,

    Mike

    Friday, July 19, 2019 4:06 AM