locked
Can I keep netcore 2.2 runtime and 3.1 in the same server without conflict? RRS feed

  • Question

  • User283528319 posted

    Hi all,

    Can I keep netcore 2.2 runtime bundling and 3.1 in the same server without conflict?

    I upgraded my project from 2.1 to 3.1 and now it is not working and I am trying to understand what is the matter

    P.S: I got 500.19 error now and also 500.31 in some trials.

    Sunday, August 30, 2020 11:35 AM

All replies

  • User753101303 posted

    Hi,

    Yes and you can use on the command line :
    dotnet --list-runtimes
    to see which runtimes are installed. 

    Try perhaps https://docs.microsoft.com/en-us/troubleshoot/iis/http-error-500-19-webpage. You should be able to find the HRESULT in the Windows Application log.

    Edit: generally speaking this is a problem on web.config such as an invalid content or a permission problem. The HRESULT value should allow to point to the exact issue.

    Sunday, August 30, 2020 3:17 PM
  • User283528319 posted

    HRESULT

    Could you tell me where should I look exactly to find that log? I don't know it.

    Sunday, August 30, 2020 7:36 PM
  • User711641945 posted

    Hi fatihbarut,

    Can I keep netcore 2.2 runtime bundling and 3.1 in the same server without conflict?

    Of course.They would not conflict with each other.But if you want to publish an asp.net core 3.1 project,you must install the corresponding version of runtime package.

    Best Regards,

    Rena

    Monday, August 31, 2020 8:42 AM
  • User753101303 posted

    See https://stackify.com/beyond-iis-logs-find-failed-iis-asp-net-requests/ and I would start with #3.

    Beyond other options for ASP.NET Core you also have http://docs.lacunasoftware.com/en-us/articles/amplia/on-premises/windows/enable-stdout-log.html

    It should allow to find some details. Most often it should be a permission issue ie are you sure the account under which your app runs is allowed to access to the site folder ?

    Monday, August 31, 2020 9:59 AM
  • User-782232518 posted

    P.S: I got 500.19 error now and also 500.31 in some trials.

    The detailed information on such error pages is the starting point, so you have to dig them first, or share out with others if you want help.

    You can install multiple .NET Core runtime versions on a machine, but the web app only loads a single version (based on its configuration).

    Tuesday, September 1, 2020 12:44 AM