none
keyboard and mouse are not responsing after first OS boot, during installation RRS feed

  • Question

  • Hi,

    I have a new model of SBC, trying to install WES7 64 bit.

    Using full IBW, the installation process goes well, but after first boot from the OS (not the PE), the keyboard and mouse stop responding.

    The manufacturer saids:

    "Add the following drivers to you image:

    INF-usb

    INT-usbhub3

    I can't find these drivers on the distribution share.

    Where can I find them.

    How can I add the drivers to the configuration file via ICE?

    Thanks,

    Avi Wertheimer

    Saturday, July 18, 2015 7:13 AM

Answers

  • Chapter 10 provides examples on where to place the driver files in the out-of-box folders.

    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Monday, July 20, 2015 5:03 PM
    Moderator
  • Hi,

    Thanks your help was great.

    To help other guys, I will describe the problem and solution:

    OS is WES7

    the SBC is MIO-2263 from Advantech

    Note: As writen in the MIO-2263 Startup manual, the SBC support only 64 OS By default

    The problem: during standard installation with IBW or using ICE, after first OS boot, the keyboard and mouse stop responding

    Reason: the USB3 driver is new and is not included in the Distribution share

    Solution:

    Driver is found at advantech web site under MIO-2263 and it is under folder with name: "other"

    within "other" folder, the driver is located at the following path

    Other\USB3.0\Windows 7\x64\3.0.0.19\SetupUSB3\Drivers\xHCI\Win7\x64

    Installation with IBW:

    mark the Modify Driver with V

    after Next, click Browse and go to the above path (assuming you copy it to your installation media

    Installation with ICE

    Make sure you have the device.pmq

    create folder for the driver as Sean explained.

    thanks

    Avi Wertheimer

    Monday, July 20, 2015 5:58 PM

All replies

  • I think the manufacturer is calling out WES8 driver modules - not WES7 since WES7 doesn't have internal support for USB 3.0. If this is a USB 3.0 port, then you are going to have to add the USB 3.0 drivers to the image.

    What is the make and model of the board?


    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Saturday, July 18, 2015 6:20 PM
    Moderator
  • Hi,SBC is MIO 2263 from advantech

    I tried to connect the keyboard and mouse to every port but all are not responding

    Their answer was - add the following dirvers to the image

    INF-usb

    INF-usbhub3

    I believe I have to extract them from the drivers package of advantech and put it in to Distribution share and add them to configuration file

    But I dont know how to add the drivers with ICE nor IBW

    Based on the fact that I red you WES7 book, cover to cover, Can you provide general guideline

    Thanks

    Avi

    Sunday, July 19, 2015 10:54 AM
  • This link will show you how to add third party drivers using driver path. In order to make keyboard and mouse work, try to put USB3.0 drivers first in the ICE. If done the steps, add the drivers later into you image, it may solve your question.

    https://msdn.microsoft.com/en-US/library/ff794955%28v=winembedded.60%29.aspx?f=255&MSPPError=-2147217396

    https://msdn.microsoft.com/en-US/library/ff795041(v=winembedded.60).aspx

    Monday, July 20, 2015 5:29 AM
  • Chapter 10 provides examples on where to place the driver files in the out-of-box folders.

    Sean Liming - Book Author: Starter Guide SIM (WEI), Pro Guide to WE8S & WES 7, Pro Guide to POS for .NET - www.annabooks.com / www.seanliming.com

    Monday, July 20, 2015 5:03 PM
    Moderator
  • Hi,

    Thanks your help was great.

    To help other guys, I will describe the problem and solution:

    OS is WES7

    the SBC is MIO-2263 from Advantech

    Note: As writen in the MIO-2263 Startup manual, the SBC support only 64 OS By default

    The problem: during standard installation with IBW or using ICE, after first OS boot, the keyboard and mouse stop responding

    Reason: the USB3 driver is new and is not included in the Distribution share

    Solution:

    Driver is found at advantech web site under MIO-2263 and it is under folder with name: "other"

    within "other" folder, the driver is located at the following path

    Other\USB3.0\Windows 7\x64\3.0.0.19\SetupUSB3\Drivers\xHCI\Win7\x64

    Installation with IBW:

    mark the Modify Driver with V

    after Next, click Browse and go to the above path (assuming you copy it to your installation media

    Installation with ICE

    Make sure you have the device.pmq

    create folder for the driver as Sean explained.

    thanks

    Avi Wertheimer

    Monday, July 20, 2015 5:58 PM