none
PNP (disable and enable) with IO before and after (certification) RRS feed

  • Question

  • Hi everybody, i'm having a trouble, actually two, the first one is that im not very good speaking english, and the other is that i can't fix this Trouble with the HCK Studio, 

    Is my first certification, that i'm trying to do, and it's a little dificult for me..

    now the important of the question..

    WDTF_Simple_IO:NETWORKSIMPLEIO.Networkplugin:setatarget()_TestNIC does not have a Gateway adress to be able to test network I/O . Two Options:

    1- Ensure test NIC has a IPv6 Gateway adress or 2- use WDTFREMOTE system parameter to specify an IPv6 Adress That The Test NIC can Ping HRESULT= 0x8004005 HRESULT= 0x8004005

    i know that there explain me 2 options to fix this trouble, but i don't know how to do it, i really don't understand too much what should i do. 

    help?

    Tuesday, May 21, 2013 5:33 PM

Answers

  • If you are testing in a network environment where the test adapter cannot be assigned an IPv6 gateway address (i.e., you are testing in a private network configuration or in a network configuration supporting only IPv4 gateway assignment), then it is recommended to use the following test configuration:

    1. Pick a remote system running Windows 7+ (client or server SKU)
    2. Use an Ethernet cable to connect the test adapter to the remote system’s LAN adapter (i.e., make a back-to-back connection between the two computers)
    3. Turn on File and Printer Sharing (http://windows.microsoft.com/en-us/windows-vista/enable-file-and-printer-sharing) on the remote system from Network and Sharing Center
    4. Note down the IPv6 address assigned to the remote system’s LAN adapter by running ‘ipconfig /all’ on the remote system
    5. Use ping.exe to ensure that you are able to ping the IPv6 address from step #5 from the test system. Use –s option to specify the IPv6 address of the test adapter as the source address.
    6. Provide IPv6 address from step #5 as WDTFREMOTESYSTEM parameter to Device Fundamentals Reliability tests when you schedule them

    *Note that IP address should be provided without the scope id. Example: fe80::205:ddff:fe27:3840


    This posting is provided AS IS with no warranties, and confers no rights.

    Tuesday, May 21, 2013 7:29 PM

All replies

  • If you are testing in a network environment where the test adapter cannot be assigned an IPv6 gateway address (i.e., you are testing in a private network configuration or in a network configuration supporting only IPv4 gateway assignment), then it is recommended to use the following test configuration:

    1. Pick a remote system running Windows 7+ (client or server SKU)
    2. Use an Ethernet cable to connect the test adapter to the remote system’s LAN adapter (i.e., make a back-to-back connection between the two computers)
    3. Turn on File and Printer Sharing (http://windows.microsoft.com/en-us/windows-vista/enable-file-and-printer-sharing) on the remote system from Network and Sharing Center
    4. Note down the IPv6 address assigned to the remote system’s LAN adapter by running ‘ipconfig /all’ on the remote system
    5. Use ping.exe to ensure that you are able to ping the IPv6 address from step #5 from the test system. Use –s option to specify the IPv6 address of the test adapter as the source address.
    6. Provide IPv6 address from step #5 as WDTFREMOTESYSTEM parameter to Device Fundamentals Reliability tests when you schedule them

    *Note that IP address should be provided without the scope id. Example: fe80::205:ddff:fe27:3840


    This posting is provided AS IS with no warranties, and confers no rights.

    Tuesday, May 21, 2013 7:29 PM
  • Hey, Thanks! before start the test i have to put the IPv6 Server into the Value of the WDTFREMOTESYSTEM, i did it and i fix it. now i'll start another question cause i have another problem. 

    but this is Fixed

    Friday, May 24, 2013 1:17 PM