locked
weird sql server error on first time loading the site RRS feed

  • Question

  • User-2016200658 posted

    I am just starting to use club site starter kit. there is a very weird sql server error when you FIRST hit the web site. but if you refresh the web site, everything start to work. there is no way I can tell my visitor refresh the web site is the trick to get to the web site. anyone can help is appreciated!

    http://www.edream.us/

    Sue

    Thursday, March 23, 2006 9:26 AM

All replies

  • User1479750397 posted

    No error for me when I clicked your link.  Since you are just starting out, a word of caution.  Whenever you add events, news, locations, ect... if there is a text box, put something in there!  Even if it is just a <space>.  The code doesn't check for this and will cause errors when you try and view/edit/delete them (DBNULL to String errors).  Make sure to check out the thread on bug fixes.

     

    Good luck

    Mark

    Thursday, March 23, 2006 11:04 AM
  • User-2016200658 posted

    Mark, thanks for your quick response. I guess the problem is on "application_onstart", only the first person visit the web site get the error. It's not consistency and difficult to reproduce the problem.

    I am more familiar with personal web site starter kit. it has the same dbnull error on textbox. I think a requirefiled validation will get rid of this. wonders why microsoft didn't make it bullet proof before it shipped.

    Thursday, March 23, 2006 11:36 AM
  • User-1476513399 posted

    Hey Sue ...

    I also had NO error(s) when loading your site.

    As s3rock mentioned ... there are many, many bugs in the Club Site.  You should definitely look through the recent forum posts from Nov 2005 ... you will see many bugs, some with fixes.  I have posted a few fixes.  I have found most of the bugs (I think).

    Good luck ...

    joe

    Thursday, March 23, 2006 3:45 PM