Provider cannot be found its not correctly installed


  • Hi,

     I developed one application using VB6.0, datbase as SqlServer and Operating System is Windowsxp.that application i made as exe.when i was executing the application its properly running in those operating systems windows95/97/2000.

    But when iam executing another windowsxp system means iam getting the error like this.


    Error :3706

    Provider not found its not installed properly

    can anybody help to slove this



    Monday, March 06, 2006 5:10 AM


All replies

  • Hi,

    Is the OS 64 bit? Also which provider are you using? Can you give the connection string?


    Mahesh B.



    Monday, March 06, 2006 7:03 PM
  • Hi,

    this is OS is windowsxp, provider is Microsft jet3.1 OLEDB Provider.




    Tuesday, March 07, 2006 12:46 PM
  • Hi,

    You need to check if this provider is available on your machine. You can check this using a UDL file. 

    To create a UDL file follow these steps

    1. Create a text file on desktop. and rename it as filename.UDL

    2. Now doubleclick and open it. Datalink properties dialog will open, Check for jet oledb provide from the provider list.

    If Jet provider is not there, you will need to download it from Microsoft site. For more information for obtaining  the latest service pack for the Microsoft Jet 4.0 Database Engine visit following link.

    Or if a different version is available on the machine ( this is most likely ), use that provider in your code and test your application.



    Mahesh B.



    Friday, March 10, 2006 10:40 PM
  • Hello,

    I ran into this post while researching the same problem I have with the Oracle OLE DB provider.  I get this provider cannot be found error when I run my app on a 64 bit Windows 2003 server.  But everything is fine on my machine whch is a XP.  My code looks something like this:


    oConn = new ADODB.Connection();

    oConn.Provider = "OraOLEDB.Oracle.1";

    sConnect = "Data Source=XX;User ID=XX;Password=XX;PLSQLRSet=1;";

    oConn.ConnectionString = sConnect;

    oConn.Open(sConnect, "XX", "XX", 0);


    As far as I can tell, the provider should be available since Oracle 10g client has been installed on the machine.  Could anyone please help me to figure out what could be wrong? 


    Sith T.
    Friday, November 07, 2008 5:39 PM