none
mailbox Database not update and status is suspended RRS feed

  • Question

  • Dear,

    I got below when I wants to update suspended database on DAG mode

    MailDB
    Failed

    Error:
    A source-side operation failed. Error An error occurred while performing the seed operation. Error: An error occurred while processing a request on server 'MAIL2'. Error: An I/O error occurred while attempting to access file 'C:\Mail Data\Program Files\Microsoft\Exchange Server\V14\Mailbox\MailDB\MailDB.edb' on source server MAIL2. Error: EseDatabaseBackupReader: PerformDatabaseRead failed with error code 0xFFFFFC18. Expected 65536 bytes read, but actually only 0 were read.. [Database: MailDB, Server: MAIL.teletalk.com.bd]

    An error occurred while processing a request on server 'MAIL2'. Error: An I/O error occurred while attempting to access file 'C:\Mail Data\Program Files\Microsoft\Exchange Server\V14\Mailbox\MailDB\MailDB.edb' on source server MAIL2. Error: EseDatabaseBackupReader: PerformDatabaseRead failed with error code 0xFFFFFC18. Expected 65536 bytes read, but actually only 0 were read.

    An I/O error occurred while attempting to access file 'C:\Mail Data\Program Files\Microsoft\Exchange Server\V14\Mailbox\MailDB\MailDB.edb' on source server MAIL2. Error: EseDatabaseBackupReader: PerformDatabaseRead failed with error code 0xFFFFFC18. Expected 65536 bytes read, but actually only 0 were read.

    EseDatabaseBackupReader: PerformDatabaseRead failed with error code 0xFFFFFC18. Expected 65536 bytes read, but actually only 0 were read.
    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.140).aspx?v=14.2.247.1&t=exchgf1&e=ms.exch.err.Ex4543D9

    Exchange Management Shell command attempted:
    update-MailboxDatabaseCopy -Identity 'MailDB\MAIL' -SourceServer 'MAIL2' -Network 'MailBoxDAG\DAGNetwork02' -DeleteExistingFiles

    Elapsed Time: 00:39:28


    Thanks, Limon ,Dhaka,Bangladesh

    Saturday, September 27, 2014 6:20 AM

All replies

  • Hi ,

    Please let allow the exchange server to choose the best source server and dag network to take automatically for seeding and this is for a checking purpose .

    I mean to say please use the below mentioned command.

    update-MailboxDatabaseCopy -Identity 'MailDB\MAIL' -DeleteExistingFiles

    Same time please make sure the database copy which you are trying to update is on the suspended state .

    get-MailboxDatabaseCopy -Identity 'MailDB\MAIL'  | fl 

    Please reply me if you have any queries.

    Regards

    S.Nithyanandham


    Thanks S.Nithyanandham

    Saturday, September 27, 2014 6:30 AM
  • Hi

     

    What I understand that when you send a mailbox database copy in Exchange server 2010 in DAG mode then you receive an error like: -

    Use this command “<mailbox database name>\<server name>” to specifying the mailbox database in the format. 

    Now resend the mailbox database with the new copy by using this command: -

    [PS] C:\>Update-MailboxDatabaseCopy –Identity “Mailbox Database 01\EX2” – DeleteExistingFiles

    The duration of sending process will depend on the size of mailbox database and speed of the network.

    I guess that the above information will be helpful for you. Please correct me if the information that I am having is wrong.

    Reply awaited.

    Thanks and regards

    Ashish@S 


    Ashish@V

    Saturday, September 27, 2014 11:29 AM
  • Dear,

    I have tried as you mentioned command. Still now i have faced same problem.


    Thanks, Limon ,Dhaka,Bangladesh

    Monday, September 29, 2014 6:53 AM
  • Hi ,

    As per my knowledge the final option would be to remove the passive copy of database "MailDB" on the exchange server "mail".

    Remove-MailboxDatabaseCopy -Identity MailDB\MAIL

    Then delete the passive copy .edb files and it's respective logs on it's location.

    Add-MailboxDatabaseCopy -Identity "MailDB" -MailboxServer "MAIL"

    Please reply me if you have any queries .

    Regards

    S.Nithyanandham


    Thanks S.Nithyanandham

    Monday, September 29, 2014 7:05 AM
  • I have already done these but no luck.

    Thanks, Limon ,Dhaka,Bangladesh

    Monday, September 29, 2014 7:09 AM
  • I have got error as below:

    A source-side operation failed. Error An error occurred while performing the seed operation. Error: An error occurred w
    hile processing a request on server 'MAIL2'. Error: Database 'd779408f-7923-4749-963a-05ab9ba77bd6' was not active on source server 'Mailboxy'.. [Database: MailDB, Server: MAIL.domain.com]
        + CategoryInfo          : InvalidOperation: (:) [Add-MailboxDatabaseCopy], SeedInProgressException
        + FullyQualifiedErrorId : CBCAC5E5,Microsoft.Exchange.Management.SystemConfigurationTasks.AddMailboxDatabaseCopy


    Thanks, Limon ,Dhaka,Bangladesh

    Monday, September 29, 2014 7:12 AM
  • Hi , 

    1.Please have a look in to the error message and it clearly says that the database is not active on the source server and also please check the active database on the source server is on healthy state . 

    Error: An error occurred w
    hile processing a request on server 'MAIL2'. Error: Database 'd779408f-7923-4749-963a-05ab9ba77bd6' was not active on source server 'Mailboxy'.. [Database: MailDB, Server: MAIL.domain.com]

    2.test-replicationhealth  | fl

    3.get-mailboxdatabasecopystatus -server "the server which is holding the active database" | fl 

    Please run the above commands to check is there any error messages coming on the output and also if possible please share me that .

    Please reply me if you have any queries.

    Regards

    S.Nithyanandham


    Thanks S.Nithyanandham

    Monday, September 29, 2014 1:27 PM