none
user getting blank page in modal RRS feed

  • Question

  • I have a htm file that I'm using in a content editor web part. The htm page is creating a vector map using jquery and css. The map is reading from the lists using the SharePoint API's. Now, the issue is, when the htm file is in a page that is in the sharepoint site, the user can see the map just fine, when I open the HTM file in a modal, the user cannot see the map, she is only able to see the text on the page and not the map. If I send her the link to the HTM file directly (http://servername/sitename/style%20%library/htm/map.htm), again, she can only see the text and not the map. I can see the map not matter how we access it, as well as my other team members (the other sharepoint developers and admins). 

    Can this be a permissions issue or something else?

    Thursday, March 30, 2017 11:50 AM

All replies

  • Hi,

    Yes, it might be permission issue. Please check the user permissions as they might not be able to access your jquery and css files.

    Also, Please check that your jquery and css files are checked in and published successfully.

    Thanks.

    Thursday, March 30, 2017 12:36 PM
  • the user is in a group that has read access to the library and all files are checked in. All files are checked in and published, like a I mentioned, she can see them if the HTM is in a content editor web part that resides in a page within the portal, its when it's on a modal or direct link

    what permission should the business user have to access the files via the modal?

    Thursday, March 30, 2017 12:41 PM
  • Please add the console log with try/catch block, it will be helpful to identify the error. 

    Thanks, Amit Kumar, LinkedIn Profile ** My Blog

    Friday, April 7, 2017 7:59 AM