none
problem with .net framework4 RRS feed

  • Question

  • Trying to install Turbotax, I got a "side by side configuration" error.  Following the help, I tried to verify my NET settings and found errors for .Net framework 4 client and extended.  Repair attempts failed.  I then tried to uninstall them to then reinstall.  However, the uninstall failed with a msg saying

    "The setup cannot run in compatibility mode."  How can I proceed?  My PC is running Vista.

    Thanks,

                 John

    Tuesday, January 17, 2012 3:07 PM

Answers

All replies

  • You can use this tool to remove .NET Framework 4.0:

    http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    Then, please follow this procedure:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

    2. Before running the installer, apply irarab's fix as follows:

    "I went to "C:\Windows\Microsoft.NET" there is a directory called "assembly".

    I looked in the directory and found some subdirectories with lots of old dot net 4 files. I renamed the directory assembly2 and tried to install Dot Net 4 and it worked!!!!

    (You can't delete the assembly directory unless you take ownership of it but you can rename it.)"

    Also, clear your %temp% directory and disable your AV software.

    3. Run the standalone installer from step 1 As Administrator.

    If the install fails, provide complete install logs as follows:

    Collect your full install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Tuesday, January 17, 2012 4:47 PM
  •  

    Still get error on new install after cleaning. As requested, I put vslogs.cab on SkyDrive.

    Tuesday, January 17, 2012 5:26 PM
  • Please post the link to your vslogs.cab.

     

    Tuesday, January 17, 2012 7:28 PM
  • https://skydrive.live.com/redir.aspx?cid=9b7896539fbb5aff&resid=9B7896539FBB5AFF!107&parid=root
    Tuesday, January 17, 2012 7:49 PM
  • Here's the core issue:

    "INSTALLMESSAGE_ERROR [Service '@C:\Windows\Microsoft.NET\Framework64\v4.0.30319\WPF\WPFFontCache_v0400.exe,-100' (WPFFontCache_v0400) could not be installed. Verify that you have sufficient privileges to install system services.]
     MSI (J:\17c157dd4791ce3cddbd0a9297a1c314\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20120117_121021532-MSI_netfx_Core_x64.msi.txt
     PerformOperation returned 1603 (translates to HRESULT = 0x80070643)"

    Are you sure you deleted everything in your %temp% directory? The contents of your vslogs.cab indicates it was not cleared prior to the last install attempt.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    Completely disable your AV software.

    Run the standalone installer you downloaded As Administrator. (I realize you are using an account with administrative priveleges, but right-click on the installer and select Run As Administrator.)

    If it still fails, you can try Michele Brina's suggestions in this thread on the same error:

    http://social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/8f732849-3923-4e6c-b878-fc3ae8964d2f

     

    Wednesday, January 18, 2012 12:39 AM
  •  

    Deleting all the files in %temp% before the .net 4 install solved that problem.  However I still

    get the "side by side configuration" error when trying to install Turbotax.  I tried reinstalling .net 3.5

    also; the installer said it was successful.  However, if I check with the netfx_setupverifier tool, it says

    that there is an error when trying to verify .net 3.5 (though 4 is indeed OK now, as are 2.0 and 3.0).

    Wednesday, January 18, 2012 3:02 AM
  • Hi John,

     

    Welcome to MSDN forum. Seems that you need to uninstall .NET Framework 3.5 completely, so please refer to this blog:

    http://blogs.msdn.com/b/astebner/archive/2008/08/01/8803442.aspx

    Note: The .NET Framework 3.5 SP1 is a slipstream replacement for the original release of the .NET Framework 3.5.  It installs the .NET Framework 2.0 SP2 and the .NET Framework 3.0 SP2 behind the scenes, and 2.0 SP2 and 3.0 SP2 are both slipstream replacements of previous versions of the .NET Framework 2.0 and 3.0.

    In order to fully uninstall the .NET Framework 3.5 SP1 and return to the .NET Framework 3.5, .NET Framework 2.0 SP1 and .NET Framework 3.0 SP1, you must use the following steps.  Note that there are different steps on Windows Vista and Windows Server 2008 than on earlier versions of Windows because the .NET Framework 2.0 and 3.0 are OS components on Windows Vista and Windows Server 2008.”

    Hope it helps.

     

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us
    Wednesday, January 25, 2012 8:15 AM
    Moderator
  •  

    I went through the uninstall/reinstall of .NET 3.5 as described on the blog you pointed me to.  It went without any error msgs.  Unfortunately, even after all that I get the same "side-by-side configuration" error when trying to install Turbotax.  I tried the Turbotax install CD on a different PC, and it worked without problem, just not on my desktop running Vista, where I need it.

    Any ideas??

    Saturday, January 28, 2012 7:07 PM
  • At this point, I would be considering a repair install of the OS.

    If you need specific help with Vista repair/reinstall procedures, ask here:

    http://answers.microsoft.com/en-us/windows/forum/windows_vista-system

    • Marked as answer by Alexander Sun Wednesday, February 1, 2012 3:20 AM
    Saturday, January 28, 2012 7:32 PM