locked
WES7 RRS feed

  • Question

  • Hi Community - I have an issue with WES7 running a Silverlight client. I'm aware this could be posted in a Silverlight forum instead, but I don't seem to have any capability to post anything there. And, it may be something specific to WES7 after all, I don't know.

    Well, here's the problem: I created a Silverlight project in VS2010, all standard stuff nothing fancy, which I can run in Visual Studio, either serviced through the ASPX page or the HTML page. I can also load the HTML page directly by double-clicking it in Windows Explorer. Then I copied the bin folder of the Silverlight project to a PC running Windows 7, where I'm also able to open the HTML and run the Silverlight application. However, if I try the same thing on a WES7, it fails.

    I'm getting the following web page error details:

     

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET CLR 2.0.50727; .NET4.0C; .NET4.0E)
    Timestamp: Fri, 2 Jan 2009 06:54:22 UTC


    Message: Unhandled Error in Silverlight Application
    Code: 4004   
    Category: ManagedRuntimeError      
    Message: System.Exception: Catastrophic failure (Fehler 0x1709. Debugging resource strings are unavailable. See http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.60531.0&File=mscorrc.dll&Key=0x1709 0x8000FFFF (E_UNEXPECTED))
       at MS.Internal.XcpImports.CheckHResult(UInt32 hr)
       at MS.Internal.XcpImports.FrameworkElement_MeasureOverride(FrameworkElement element, Size availableSize)
       at System.Windows.FrameworkElement.MeasureOverride(Size availableSize)
       at System.Windows.FrameworkElement.MeasureOverride(IntPtr nativeTarget, Single inWidth, Single inHeight, Single& outWidth, Single& outHeight)    

    Line: 54
    Char: 13
    Code: 0
    URI: file:///C:/Program%20Files/Kistler/Kistler.Skyros.Prototype01.SilverlightClientTestPage.html

    Any hints or suggestions are most welcome. Thanks - David


    Wednesday, June 29, 2011 9:09 AM

Answers

  • Hi Andreas - thank you for your suggestion / solution. Building WES7 based on the "Application Compatibility Template" has indeed resolved my issue. Thank you & best regars, David
    • Marked as answer by David Maeder Monday, July 4, 2011 2:20 PM
    Monday, July 4, 2011 2:20 PM

All replies

  • Hello David Did you have tested the Silverlight Application on a WES7 image build with the "Application Compatibility Template"? If not, please do it. If the error also occurs with the "Application Compatibility Template", take a look with the dependency checker. Maybe this will show you a missing component... Best regards, Andreas
    Wednesday, June 29, 2011 1:23 PM
  • Hi Andreas - thank you for your suggestion / solution. Building WES7 based on the "Application Compatibility Template" has indeed resolved my issue. Thank you & best regars, David
    • Marked as answer by David Maeder Monday, July 4, 2011 2:20 PM
    Monday, July 4, 2011 2:20 PM
  • Now that you have have somethign working in a full image. If you want to create a smaller image, you might want to download the Silverlight Templated - http://www.microsoft.com/windowsembedded/en-us/downloads/windows-embedded-compatible-applications-chooser.aspx so you can included only the packages you need to run Silverlight.

     

    -Sean

     


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - ProGuide to WES 7, XP Embedded Advanced, WEPOS / POS for .NET Step-by-Step
    Monday, July 4, 2011 4:20 PM