locked
Failed Installation of .NET Framework 3.5 Service Pack 1 RRS feed

  • Question

  • I have Windows Vista Home Premium, Service Pack 1, 32-bit Operating System. 

    My Windows Updater has been trying to install Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86 since June, always unsuccessfully.  I have followed up on error codes (often it is: 800B0100) and downloaded extra tools (e.g. system readiness tool KB947821) but still have not been able to successfuly install the update.

    I also tried downloading the 3.5 Service Pack 1 on its own from Microsoft download center.  When installing I receive the following error:

    [09/16/09,09:56:48] Microsoft .NET Framework 3.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 3.0SP1 (CBS). MSI returned error code -2146762496
    [09/16/09,09:56:58] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.0SP1 (CBS) is not installed.

    Thanks for any suggestions!

    Wednesday, September 16, 2009 10:39 AM

Answers

  • Hi Jessie,

    Thank you for your post.

    Thank you for your information. :)

    Error code "0x800B0100" means "No signature was present in the subject".
    One of the possible cause of this error could be corrupted Windows Installer. You can try upgrading Windows Installer to the latest Version 4.5.

    Another possible cause could be damaged .NET Framework 3.5 SP1 installer.
    Please try using some download manager software to download .NET Framework 3.5 Service Pack 1 (Full Package) again.

    Then, please check whether you have turned on the windows feature of .NET Framework 3.0.
    Please go to Control Panel -> Programs and Features -> Turn Windows features on or off -> Check the box next to Microsoft .NET Framework 3.0.

    Use Verification Tool to verify .Net Framework 2.0, 3.0 and 3.5. If .Net Framework 2.0 and 3.0 cannot be verified on your computer, you can try to follow the steps mentioned in the following blog to repair the .NET Framework 2.0 and 3.0 on Windows Vista.
    See: http://blogs.msdn.com/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx
    If .NET Framework 3.5 is not verified, please remove it.

    If no avail, please try to use collect tool to collect the log files of .NET Framework 3.5 SP1 from your "%temp%" folder?
    http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx

    You can upload your log files to SkyDrive and post the link back here.

    Steps:
    - Try to clean your "%temp%" folder
    - Install .NET Framework 3.5 SP1 (The installer must be run with administrator privileges - Right click the installer >> Click "Run as administrator")
    - Collect the logs from "%temp%" folder
    - Upload vslogs.cab file

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Wednesday, September 23, 2009 3:43 AM typo
    • Marked as answer by YiChun Chen Wednesday, September 23, 2009 3:43 AM
    Thursday, September 17, 2009 7:43 AM