none
Debugger hangs after loading Accesibility.dll Visual Studio 2015 C#

    Question

  • I am using Visual Studio 2015, writing a program in C#. Up until a couple hours ago, my program was running fine and I had no problem running the debugger to test code. Then, I tried to run it (not using debugging) and it seemed to take forever to run; I'm dealing with large data, so it was possible that it was still processing. After a LONG time, nothing was happening, but it was frozen somewhere, so I restarted my computer. Ever since then, I haven't been able to get anything to run.

    When I go into debug mode now, the last output I see is 'TagCloud.vshost.exe' (CLR v4.0.30319: TagCloud.vshost.exe): Loaded 'C:\WINDOWS\Microsoft.Net\assembly\GAC_MSIL\Accessibility\v4.0_4.0.0.0__b03f5f7f11d50a3a\Accessibility.dll'. Symbols loaded.

    Then nothing. It will sit there forever. I'm not sure what's supposed to be next, or what to do from here. This is my senior project, due Tuesday, and I was testing the last element... and now nothing. The only code I changed from the last time it worked until now was increasing the value of a for loop... nothing that should cause a logical fault in the program.

    Friday, April 29, 2016 3:31 AM

Answers

  • Try restarting the machine again using normal procedure and make sure that it is in good condition (check for updates, verify if other programs work well, run a recommended reliable antivirus, etc.). Then start Visual Studio and go to menu, Options, Debugging, Symbols, and disable the symbol servers, if any. Then load your project and execute “Rebuild All” from Build menu.

    Then try starting it using <F10> key, i.e. in step-by-step mode. If it seems to start, then run with <F5>. If it then hangs unexpectedly, then select “Break All” from Debug menu and investigate the location, call stack, threads, etc.

    If possible, try on other machines too.

    Some kinds of problems can be caused by certain incompatible antivirus software. Which one are you using?

    Friday, April 29, 2016 5:29 AM