none
Visual Studio 2015 - Can't open a new projet

    Question

  • I installed Visual Studio 2015, i needed to create a visual c++ projet, i opened the new project window normally, and than i downloaded the requirements. after all is done, and both Virtual studio and the pc restarted, Whenever i click "New Project..." on the start page i get this error : 


     new project i get this error :

    new project/item dialog could not be initialized due to error: could not load file or assembly 'Microsoft.VisualStudio.ApplicationInsights, Version=3.3.0.0, Culture=neutral,PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.



    Can anyone help me ? thanks!

    Thursday, November 12, 2015 8:30 AM

Answers

  • Hi,

    Thank you for posting in MSDN forum.

    For this issue, to make sure whether it is related to the installation, please go to Control Panel to repair your visual studio first. And make sure that your account is the administrator.

    Besides, I doubt that your template maybe corrupted, please reset your templates to see if it helps:

    1) Open Windows Explorer, and navigate to <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files or Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE);
    2) Delete the ItemTemplatesCache, ProjectTemplatesCache folder;
    3) Open Visual Studio Command Prompt under Start menu -> All Programs -> Microsoft Visual Studio -> Visual Studio Tools (run it with administrative privilege);
    4) Run the devenv /InstallVSTemplates switch;
    5) Run the devenv /Setup switch;

    Best Regards,

    Jiayi


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Friday, November 13, 2015 5:38 AM
    Moderator

All replies

  • Hi,

    Thank you for posting in MSDN forum.

    For this issue, to make sure whether it is related to the installation, please go to Control Panel to repair your visual studio first. And make sure that your account is the administrator.

    Besides, I doubt that your template maybe corrupted, please reset your templates to see if it helps:

    1) Open Windows Explorer, and navigate to <Visual Studio Installation Path>\Common7\IDE (by default is C:\Program Files or Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE);
    2) Delete the ItemTemplatesCache, ProjectTemplatesCache folder;
    3) Open Visual Studio Command Prompt under Start menu -> All Programs -> Microsoft Visual Studio -> Visual Studio Tools (run it with administrative privilege);
    4) Run the devenv /InstallVSTemplates switch;
    5) Run the devenv /Setup switch;

    Best Regards,

    Jiayi


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Friday, November 13, 2015 5:38 AM
    Moderator
  • Thank you, this worked for me. Voted up :)
    Thursday, November 03, 2016 2:17 PM