locked
Disable power saving in an externally connected Storage spaces volume RRS feed

  • Question

  • I have an externally USB-3 connected storage device I use as a central archive for a backup application. It consists of 4 each Seagate Barracuda 7200.14 ST3000DM001 3TB 7200 RPM hard drives in a Mediasonic ProBox HF2-SU3S2 HDD Enclosure. These 4 drives are configured as a mirrored Storage Space running the ReFS file system (drive F:\).

    The Storage Spaces volume was created under Windows 8.1 and everything had been working correctly (i.e. for close to a year backups ran) until I upgraded to the Windows 10 OS and upgraded my Storage Spaces pool. Ever since these upgrades, the drives in my backup archive spin down and the enclosure powers off after a period of inactivity.

    My troubleshooting efforts have consisted of the following:

    I edited the Power Options settings for the “Balanced” power option in Control Panel to never put the computer to sleep for both “On Battery” and “Plugged In” computer states. This is a desktop PC on a UPS and I should not need to change the “On Battery” state case, but I wanted to make sure to eliminate any ambiguity in my troubleshooting process.

    I set the “Advance settings” under the "Balanced" power option for both “On battery” and “Plugged in” to the following:

    Hard disk > Turn off hard disk after >                “Never”

    Sleep > Sleep after >                                       “Never”

    Sleep > Allow hybrid sleep >                             “Off”

    Sleep > Hibernate after >                                  “Never”

    USB settings > USB selective suspend setting >   “Disabled”

    I went into Device Manager and set the Power Management properties of the Universal Serial Bus controllers to:

    Generic USB Hub(s) >                                 (Unchecked/Disabled) “Allow the computer to turn off this device to save power”

    USB Root Hub(s) >                                     (Unchecked/Disabled) “Allow the computer to turn off this device to save power”

    USB Root Hub xHCI(s) >                             (Unchecked/Disabled) “Allow the computer to turn off this device to save power”

    My workaround to keep this volume online is to run a little program called KeepAliveHD... but I should not have to do this.

    Is there a Storage Spaces setting to keep these drives active/alive whenever the PC is running?

    Thanks.

    OS Name                                                       Microsoft Windows 10 Pro

    Version                                                          10.0.10586 Build 10586

    System Manufacturer                                       MSI

    System Model                                                 MS-7751

    System Type                                                  x64-based PC

    Processor                                                      Intel(R) Core(TM) i7-3770K CPU @ 3.50GHz, 3501 Mhz, 4 Core(s), 8 Logical Processor(s)

    BIOS Version/Date                                          American Megatrends Inc. V17.12, 10/30/2013

    Drive                                                             F:

    Description                                                     Local Fixed Disk

    Compressed                                                   No

    File System                                                    ReFS

    Size                                                              5.45 TB (5,992,351,793,152 bytes)

    Free Space                                                    2.96 TB (3,256,389,140,480 bytes)

    Sunday, February 28, 2016 7:44 PM