locked
Application Error: the instruction at 0x72f46954 referenced memory error

    Question

  • I've had a recurring error on shut down and restart.  Here is what it says:

     

    MS_WebcheckMonitor: explorer.exe - Application Error

     

    The instruction at 0x72f46954 referenced memory at 0x00000000. The memory could not be read. Click OK to terminate the program

     

    Any suggestions

    Saturday, October 15, 2011 12:27 AM

Answers

All replies

  • Gription,

    Has this been happenning since you first installed Windows Developer Preview or had it been restarting/shutting down normally and suddenly you started seeing this error at restart/shutdown?  If not, had you recently installed new software or added new devices around the time you noticed this error at restart/shutdown?  A couple of things to check -- look in Device Manager (WIN + r, type devmgmt.msc, press Enter) and check for any "x", "!" or "?" next to any of the devices listed.  Try a clean boot -- WIN + r, type msconfig.exe, press Enter - on the General tab of the System Configuration GUI, select "Diagnostic startup", click OK, then Restart.  Once you've booted up clean and logged back in, peform a shutdown and see if you still get that error.  Reply with results.

    You'll have to go back into the System Configuration GUI once you've done this test and select "Normal startup" from the General tab, click OK, then click restart to get back to normal operation.

     

    Regards,  


    Gary
    Saturday, October 15, 2011 9:07 PM
    Answerer
  • I am getting this error as well.  It does not happen every session, only some.  It is apparent when the PC will not shutdown. Pressing the power button to sleep, then resuming will show the error (normally it is hidden behind the shutdown screen).  Once you dismiss the error, the Developer PC (mine is the Samsung Developer Preview Tablet) will shutdown normally.
    Ryan
    Wednesday, December 28, 2011 3:32 PM
  • Please check event viewer to see if you have any errors referencing shutdown or power.

    If it continues to occur, please submit feedback.

    You can submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program. If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview. There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here.

    If you are prompted for an invitation code, please enter the following key. MSDN-76H9-3CFP

    https://connect.microsoft.com/site1147/InvitationUse.aspx?ProgramID=7221&InvitationID=MSDN-76H9-3CFP


    Thanks,


    Marilyn
    Wednesday, December 28, 2011 5:33 PM
    Moderator
  • I've had a recurring error on shut down and restart.


    If this is really recurring and even partially reproducible, definitely report it.

    However, one thing that I think is important is to know the exact shut down procedure that you are using.   E.g. I had one the other day which crashed in the Settings screen, the only time that I deliberately tried to use that dialog via keyboard only.   The ones that occur sporadically for me usually involve a parameterized shutdown via a cmd window; then it is usually in Clock and Time.

    http://social.msdn.microsoft.com/Forums/en-US/windowsdeveloperpreviewgeneral/thread/405e517a-7872-4d37-b55a-0fca8f763e84

    I just noticed that nobody answered my question about whether telemetry is catching these.   Otherwise I suppose I should try to hunt down the latest one from Event Viewer (yuck) and add it to my thread.

     

    FYI

    Robert Aldwinckle
    ---

    Wednesday, December 28, 2011 7:16 PM
  • I see this, too on most shutdowns. Often the shutdown is stopped becasue of this and I'm back to the Metro startscreen.

    Eventlog doesn't Show any error details. I gave it up. Wait for the beta and hope that this is fxed.


    "A programmer is just a tool which converts caffeine into code"

    Wednesday, December 28, 2011 7:25 PM
  • I see this, too on most shutdowns.


    WebCheckMonitor?   What is that?   If you are using Remote Desktop that would be one difference with my case.

    Wow.  Is this a regression of some kind?   <eg>

    http://www.tomshardware.com/forum/22445-45-getting-ms_webcheckmonitor

    (BING search)

    Advises  (c. 2005):

     regsvr32 /u WEBCHECK.DLL

     

    And there is one in W8!

    <cmd_output>


    C:\WINDOWS\system32>dir/a/b/s webcheck*
    C:\WINDOWS\system32\webcheck.dll

    </cmd_output>


    Caveat emptor!

    (Or hopefully re-registering would repair any damage done by the experiment?  <eg>)

     

    Good luck

    Robert
    ---

    Wednesday, December 28, 2011 7:58 PM