locked
Azure notebooks / Jupyter / how to install GLPK? RRS feed

  • Question

  • Hello,

    I was giving a try to Azure Notebooks.
    I tried a test notebook based on pyomo and GLPK.
    From Jupyter, I installed pyomo without problem (! pip install pyomo).

    For GLPK, the pip command ended by a failure.
    Still from Jupyter, I then tried conda (conda install -c conda-forge glpk).
    It started the install as usual, but then came with a prompt in the Jupyter notebook:

    The following NEW packages will be INSTALLED:    
    glpk: 4.61-0  conda-forge   
    gmp:  6.1.2-0 conda-forge
    Proceed ([y]/n)?

    Of course, from within Jupyter, I have no way to answer this prompt.
    I could not solve the problem  by using the terminal. (conda is unknown and pip failed)

    Would you know how to get pyomo and glpk working on Azure Notebooks?
    Would you know how to answer a prompt in Jupyter?

    More generally, I have this question: is it possible to work on Azure Notebook as easily (!) as on my laptop?
    If that would be possible, I would be ready to switch to Azure.
    And I would also like to share and get more flexibility in this way.
    Otherwise, I would just forget (once more) about personal cloud computing (PC-C!)

    Thanks,

    Michel





    • Edited by Lalbatros Friday, June 9, 2017 11:09 AM
    Friday, June 9, 2017 11:07 AM

All replies

  • please see:

    https://conda.io/docs/commands/conda-install.html  

    you want --yes

    re jupyter on laptop: yes.  

    1. install anaconda from continuum.io

    2. start jupyter 

    thx

    Saturday, June 10, 2017 2:01 AM
  • From within Jupyter I simply used:

    !conda install -c conda-forge pyomo -y

    Please, notice that with "-y" Python will accept "Yes" for any question during the installation.

    I hope it works for you.



    Wednesday, August 28, 2019 1:47 AM