locked
I cannot get the touch keyboard to display at all

    Question

  • Hi there, for some reason the soft keyboard no longer displays inside the Simulator in Win 8 RTM / VS 2012 RTM.

    I take it that all I should have to do to get it to display is to use the "Basic Touch Mode" of the Simulator and touch a textbox?  If this is all I should have to do, then there's a bug somewhere, because it will not popup.  I cannot even get it to display inside other native apps, like IE (all in the Simulator).

    Does anyone know if there is any other way to invoke the touch keyboard?

    -----------

    UPDATE: 14 hours later.  The touch keyboard still doesn't display in response to touch mode in the Simulator. I would really appreciate some support from MSFT on this. It's an easy demonstrable problem and I'm quite prepared to assist in sorting this out.  At the moment, this is a showstopper for my development.  

    thanks

    k


    Monday, August 20, 2012 7:00 AM

All replies

  • Hello,

    A couple of diagnostic questions:
    1) Open up task manager on the simulator (right click the task bar and select task manager)
    2) Is the Touch Keyboard and Handwriting Panel running? (tabtip.exe)
    3) On the services tab, is the Touch keyboard and Handwriting Panel service started?
    4) On the taskbar, is there a keyboard icon?
    5) Does pressing the keyboard icon on the taskbar cause the touch keyboard to appear?

    Tuesday, August 21, 2012 5:15 AM
  • Hi there, answers:

    1. If you do this inside the Simulator an error says "The request is not supported", however, I downloaded process explorer and used that
    2. TabTip.exe was not initially running
    3. Yes, the service is running
    4. Yes, I do have the keyboard icon, however not inside the Simulator window, actually on my real computer taskbar
    5. If I press it, the keyboard does appear, outside the Simulator.

    TabTip.exe only started running once I'd pressed the touch keyboard icon on my main taskbar.

    thanks

    Kris

     

     

    Tuesday, August 21, 2012 7:06 AM
  • Thanks Kris,

    It appears to me that something is wrong with the detection of a digitizer inside the simulator. You should have a keyboard icon on the taskbar of the simulator when a digitizer is present. To confirm, can you press the windows key + break on the simulator? That should bring up the system properties in the simulator. There is a item called "Pen and Touch". Can you report back as to what it says?

    Tuesday, August 21, 2012 6:17 PM
  • Hi there, thanks for the message.

    I'd been using my PC away from my usual office. A few hours ago, I plugged in my usual USB devices (a hub, printer, Lumia, Skype headset) and now the keyboard appears OK.  It's strange but true!

    The keyboard icon now appears inside the Sim and the System Properties say "Limited Touch support with 5 touch points"

    If it happens again, I'll report back on this thread what it says.  I hope that this is logged as a bug, as it's cost me days of development time, which I can ill afford.

    Thank you for your support

    Tuesday, August 21, 2012 6:35 PM
  • I'm glad it's working now. I will pass the information along.

    -Anil

    Tuesday, August 21, 2012 7:05 PM
  • Hi Anil, please could you also look at this as well, thanks. it's another blocker on my project. thanks.
    Friday, September 14, 2012 9:04 PM
  • Hi,

    I'm having the same issue: Keyboard not showing in the simulator.

    I cannot start the taskmanager or system properties or service manager, all such actions give me an "The request is not supported" error. I assume the user on the simulator (which is really just a virtual machine, right?) is not administrator.

    I can manually start the tabtib.exe, but then (as with daysleeper55) it's only shown in the desktop mode.

    Is there a way to reset the simulator?

    Best regards / Jon

    Thursday, November 22, 2012 9:26 AM
  • I actually found the way to get it working for me was to plug in all the USB devices I had plugged in when it was last working.  Sounds weird. But it stopped working for me when I went away for a few days.  Came back, plugged everything in and it all started working again!
    Saturday, December 01, 2012 4:26 PM
  • I had the same problem as you guys. Visual Studio 2012 on an old Compaq NC6400 in a WPF C# Windows Store app.

    To get things working I exited Visual Studio, enabled the desktop keyboard (TabTip) and then removed and insterted my mouse usb dongle (only USB device ever used on the laptop)  and when I reloaded the project in Visual Studio and ran the simulator the keyboard popped up as rquired.

    Also I made sure I was in touch mode in the simulator before the app loaded.

    For reference my develpment laptop for this project is old and does not have hardware touch support.

    Regards,

    Jon Hughes

    Tuesday, December 17, 2013 2:02 AM