none
BizTalk and IBM MQ

    Question

  • Can anyone please advice if BizTalk Server 2010 is compatible with IBM MQ 7.5 using MQSC adapter.

    I'm working on a environment where BizTalk Server 2010 and IBM MQ 7.0 (Server) are on the same server  using MQSeries Adapter for connectivity. I'm planning to migrate MQ to a different server and install the client on to BizTalk server.

    Any recommendations/suggestions please?

    Thanks,

    Saranya

    Tuesday, November 15, 2016 10:59 PM

Answers

  • Can anyone please advice if BizTalk Server 2010 is compatible with IBM MQ 7.5 using MQSC adapter.

    I'm working on a environment where BizTalk Server 2010 and IBM MQ 7.0 (Server) are on the same server  using MQSeries Adapter for connectivity. I'm planning to migrate MQ to a different server and install the client on to BizTalk server.

    Any recommendations/suggestions please?

    Thanks,

    Saranya

    MQ 7.5 is not supported with Bt2010.

    Your plan is good and works well. You can install the MQ server on a different server and have the MQ client installed on BizTalk messaging servers. Make sure your hosts are 32 bit for MQSC adapters. 64 bit does work but sometimes you will notice that a 0KB message is received instead of the original message and the message is lost. So keep inmind to have 32 bit hosts for MQSC.


    Pi_xel_xar

    Blog: My Blog

    BizTalkApplicationDeploymentTool: BizTalk Application Deployment Tool/

    • Marked as answer by smoorthy Monday, November 21, 2016 5:02 AM
    Wednesday, November 16, 2016 8:16 AM
    Answerer
  • Hi Saranya

    As already suggested, MQ 7.5 is not supported with BizTalk 2010.

    However, you can make it work with MQ 7.0. So, as you have already mentioned, you can have BizTalk Server + MQSC adapter + 7.0 MQ Client on one server; and you can install IBM MQ Server 7.0 on a 2nd server.

    Refer below article on this-

    http://social.technet.microsoft.com/wiki/contents/articles/18316.biztalk-server-mqseries-and-mqseries-client-mqsc-adapters.aspx


    Thanks Arindam


    Wednesday, November 16, 2016 11:12 AM
    Moderator

All replies

  • Hi Saranya,

    Sorry, it is not a supported configuration.

    Refer: http://social.technet.microsoft.com/wiki/contents/articles/18316.biztalk-server-mqseries-and-mqseries-client-mqsc-adapters.aspx

    Supported IBM WebSphere MQ versions

    'Yes' means it's supported. 'No' means it is not supported. When "No", that version may still work.

      WebSphere MQ 8 WebSphere MQ 7.5 WebSphere MQ 7.1 WebSphere MQ 7.0 WebSphere MQ 6.0 WebSphere MQ 5.3
    MQSeries (BizTalk 2013) Yes, with HIS CU3  Yes Yes Yes - 7.0.1.9 and later Yes - MQ 6.0.2.12 and later No
    MQSeries (BizTalk 2010) No No No Yes No No
    MQSeries (BizTalk 2009) No No No Yes Yes No
    MQSeries (BizTalk 2006 R2) No No No No Yes Yes
    MQSeries (BizTalk 2006) No No No No Yes Yes
                 
    MQSC (HIS 2013) Yes, with HIS CU3  Yes Yes No No No
    MQSC (HIS 2010) No No No Yes No No
    MQSC (HIS 2009) No No No Yes Yes No
    MQSC (HIS 2006) No No No No Yes Yes

    WebSphere MQ Client minimum requirements:

    • IBM WebSphere MQ Client 5.3 with Fix Pack 5.0.1.0 or higher
    • IBM WebSphere MQ Client 6.0 with Fix Pack 6.0.1.1 or higher
    • IBM WebSphere MQ Client 7.0 with Fix Pack 7.0.0.1 (required for 64-bit)
    • IBM WebSphere MQ Extended Transactional Client 6.0 with Fix Pack 6.0.1.1 (for transactional support)
    • IBM WebSphere MQ Extended Transactional Client 7.0 with Fix Pack 7.0.0.1 (for transactional support)


    Rachit Sikroria (Microsoft Azure MVP)

    Tuesday, November 15, 2016 11:57 PM
    Moderator
  • Hi Saranya,

    No Biztalk 2010 is not compatible with the IBM MQ7.5 , Biztalk 2010 is compatible with MQ7.0 (above 7.0.1.9) and IBM MQ 6.0 (above 6.0.2.12)

    Refer the Compatibility matrix as showbn below.

    Reference : Technet wiki

    In order for you to understand the integration between the the IBM MQ and Biztalk,

    I would suggest you visit this detailed article BizTalk Server: MQSeries and MQSeries Client (MQSC) adapters

    Regards


    Mandar Dharmadhikari



    Wednesday, November 16, 2016 3:32 AM
    Moderator
  • Can anyone please advice if BizTalk Server 2010 is compatible with IBM MQ 7.5 using MQSC adapter.

    I'm working on a environment where BizTalk Server 2010 and IBM MQ 7.0 (Server) are on the same server  using MQSeries Adapter for connectivity. I'm planning to migrate MQ to a different server and install the client on to BizTalk server.

    Any recommendations/suggestions please?

    Thanks,

    Saranya

    MQ 7.5 is not supported with Bt2010.

    Your plan is good and works well. You can install the MQ server on a different server and have the MQ client installed on BizTalk messaging servers. Make sure your hosts are 32 bit for MQSC adapters. 64 bit does work but sometimes you will notice that a 0KB message is received instead of the original message and the message is lost. So keep inmind to have 32 bit hosts for MQSC.


    Pi_xel_xar

    Blog: My Blog

    BizTalkApplicationDeploymentTool: BizTalk Application Deployment Tool/

    • Marked as answer by smoorthy Monday, November 21, 2016 5:02 AM
    Wednesday, November 16, 2016 8:16 AM
    Answerer
  • Hi Saranya

    As already suggested, MQ 7.5 is not supported with BizTalk 2010.

    However, you can make it work with MQ 7.0. So, as you have already mentioned, you can have BizTalk Server + MQSC adapter + 7.0 MQ Client on one server; and you can install IBM MQ Server 7.0 on a 2nd server.

    Refer below article on this-

    http://social.technet.microsoft.com/wiki/contents/articles/18316.biztalk-server-mqseries-and-mqseries-client-mqsc-adapters.aspx


    Thanks Arindam


    Wednesday, November 16, 2016 11:12 AM
    Moderator
  • Thanks for the 32 bit host information. Noted.
    Monday, November 21, 2016 5:03 AM