locked
ASP.NET Web Site Administration Tool RRS feed

  • Question

  • User-434443194 posted

    Hello,

    I am trying to create memberships and roles. On Visual Web developer I goto Website-ASP.NET Configuaration. I click on security and I get the following error:

    There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store.
    
    The following message may help in diagnosing the problem:  The connection name 'ApplicationServices' was not found in the applications configuration or the connection string is empty. (C:\Users\Administrator\Documents\Visual Studio 2010\WebSites\WebSite1\web.config line 23)

    This is my web.config file

    <?xml version="1.0"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <connectionStrings>
        <add name="HelpDesk" connectionString="Server=WIN-8N4RRG8JH4Q;Database=SPCC HelpDesk;Integrated Security=True" providerName="System.Data.SqlClient"/>
      </connectionStrings>
      <system.web>
        <pages theme="Blue">
          
        </pages>
        <compilation debug="true" targetFramework="4.0"/>
        <authentication mode="Forms">
        </authentication>
        <authorization>
          <deny users="?" />
        </authorization>
        <membership>
          <providers>
            <clear/>
            <add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="ApplicationServices" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/"/> 
          </providers>
        </membership>
        <profile>
          <providers>
            <clear/>
            <add name="AspNetSqlProfileProvider" type="System.Web.Profile.SqlProfileProvider" connectionStringName="ApplicationServices" applicationName="/"/>
          </providers>
        </profile>
        <roleManager enabled="true">
          <providers>
            <clear/>
            <add name="AspNetSqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="ApplicationServices" applicationName="/"/>
            <add name="AspNetWindowsTokenRoleProvider" type="System.Web.Security.WindowsTokenRoleProvider" applicationName="/"/>
          </providers>
        </roleManager>
      </system.web>
    
    
      <!-- Allow access to App_Themes directory -->
      <location path="App_Themes">
        <system.web>
          <authorization>
            <allow users="?"/>
          </authorization>
        </system.web>
      </location>
    
      <!-- Allow access to Images directory -->
      <location path="Images">
        <system.web>
          <authorization>
            <allow users="?"/>
          </authorization>
        </system.web>
      </location>
    
      <system.webServer>
        <modules runAllManagedModulesForAllRequests="true"/>
      </system.webServer>
    </configuration>


    I am new to this and not sure how to resolve this. Any help is greatly apprciated.

    Thank You

     

    EIDIT: I changed the connection String Name to: LocalSqlServer and I get this error:

    There is a problem with your selected data store. This can be caused by an invalid server name or credentials, or by insufficient permission. It can also be caused by the role manager feature not being enabled. Click the button below to be redirected to a page where you can choose a new data store. 
    
    The following message may help in diagnosing the problem:  Unable to connect to SQL Server database. 

    Wednesday, April 3, 2013 11:55 AM

Answers

  • User-1137493631 posted

    "... role manager feature not being enabled.." , i can see that you have enabled rolemanager, anhow please try one more time to make sure you have enabled rolemanager or not.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, April 3, 2013 7:34 PM