none
Hourly Scheduler job doesn't start right at oclock RRS feed

  • Question

  • a task on schedule job collection to run once an hour. It was all fine in passed few months. Since Feb 7th. It doesn't start right at oclock. Sometime even starts at +1 min. Can you check it what's wrong from there? Thanks.
    Wednesday, February 15, 2017 2:36 PM

All replies

  • Hi,

    Could you please check if you have "StartTime" set on your job?  If not, could you please add a "StartTime" on your job (e.g. 2/7/2017 6:00:00 PM).  This will make sure that Scheduler job will always based on your "StartTime" to move to the next hour.  If "StartTime" isn't provided we will use the last execution time and move to the next hour.

    Thanks,

    Ping

    Wednesday, February 15, 2017 6:24 PM
  • To ensure it starts at 0 minutes of every hour, you have two options:

    • Make sure the start time of your job is at 0 minute.
    • Or, use advanced schedule and specify "0" for minute.
    Wednesday, February 15, 2017 6:42 PM
    Owner
  • Hi,

    Looks like you have "StartTime" set and this isn't the actual issue with the +1 minute delay on job execution.  The issue was that we were under larger load than expected.  We have scaled out number of instances running job execution and this should bring down the job execution delay already.  Would you please check and let us know if that's not the case.

    Thanks,

    Ping

    Wednesday, February 15, 2017 7:31 PM
  • It seems back to normal now. Thanks so much Pingjiang!

    Saturday, February 18, 2017 3:44 PM