none
Publish Prerequisites from same location as my project RRS feed

  • Question

  • Dear Experts,

    On wish To publish my project and have the Prerequisites from the local pc where the app set up exe is

    most of these files i copied and read  the article 

    https://msdn.microsoft.com/en-us/library/hh873130(v=vs.110).aspx


    out of other errors for putting prerequisites files following  last error i am not able to solve , as i m not getting the file to copy at that place C:\Program Files (x86)\Microsoft SDKs\Windows\v8.0A\Bootstrapper\Packages\DotNetFX35SP1\dotNetMSP

    Error 6 To enable 'Download prerequisites from the same location as my application' in the Prerequisites dialog box, you must download file 'DotNetFX35SP1\dotNetMSP\x86\NetFX2.0-KB948609-v6001-x86.msu' for item '.NET Framework 3.5 SP1' to your local machine. For more information, see http://go.microsoft.com/fwlink/?LinkId=239883. KingsPUMP

    can somebody help me to do it

    Friday, November 27, 2015 8:17 AM

All replies

  • Hi Sushil,

    Thank you for posting in MSDN forum.

    If you OS is Win 7,you could install .NET Framework 2.0 from other way, but by going to Control Panel->Turn Windows features on or off, enable .NET Framework 3.5 

     .NET Framework 3.5 is included in Win 7 by default

    If not , please download it and install .net framework 3.5 SP1 on your machine, here is the download link:

    https://www.microsoft.com/en-us/download/details.aspx?id=22

    Best Regards,

    Wen Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, November 30, 2015 8:31 AM
    Moderator
  • I am Having Windows 10 Installed On My Laptop and i publishing a Vs2012 (11.0.61030 update 4) Project.

    Even Downloading From https://www.microsoft.com/en-us/download/details.aspx?id=22

    did not run and resolve the problem

    the 5 files 

    Error 6 To enable 'Download prerequisites from the same location as my application' in the Prerequisites dialog box, you must download file 'DotNetFX35SP1\dotNetMSP\x86\NetFX2.0-KB948609-v6001-x86.msu' for item '.NET Framework 3.5 SP1' to your local machine. For more information, see http://go.microsoft.com/fwlink/?LinkId=239883. KingsPUMP

    Error 7 To enable 'Download prerequisites from the same location as my application' in the Prerequisites dialog box, you must download file 'DotNetFX35SP1\dotNetMSP\x86\NetFX3.0-KB948610-v6001-x86.msu' for item '.NET Framework 3.5 SP1' to your local machine. For more information, see http://go.microsoft.com/fwlink/?LinkId=239883. KingsPUMP
    Error 8 To enable 'Download prerequisites from the same location as my application' in the Prerequisites dialog box, you must download file 'DotNetFX35SP1\dotNetMSP\x64\NetFX2.0-KB948609-v6001-x64.msu' for item '.NET Framework 3.5 SP1' to your local machine. For more information, see http://go.microsoft.com/fwlink/?LinkId=239883. KingsPUMP
    Error 9 To enable 'Download prerequisites from the same location as my application' in the Prerequisites dialog box, you must download file 'DotNetFX35SP1\dotNetMSP\x64\NetFX3.0-KB948610-v6001-x64.msu' for item '.NET Framework 3.5 SP1' to your local machine. For more information, see http://go.microsoft.com/fwlink/?LinkId=239883. KingsPUMP

    where are these files and how to install them in GAC on a windows 10, 64 bit pc

    Tuesday, December 1, 2015 4:45 AM
  • Hi Sushil,

    If an app requires the .NET Framework 3.5, but doesn't find that version enabled on your computer, it displays the prompt for installing the .NET Framework 3.5 on demand, either during installation, or when you run the app for the first time after its installation. In this prompt, you can choose the option “Install this feature” to enable the .NET Framework 3.5 on the computer

    At first, you could try to use dism command enable .NET Framework 3.5 (include .NET 2.0 and 3.0) feature in offline mode, please follow the steps below:

    Step 1 :
    Insert Windows 8 DVD or mount ISO image. The source of this feature can be found in folder E:\sources\sxs. (In this case E: the user’s drive letter on which the user has loaded Windows 8 Media.)

    Step 2 :
    Open CMD.EXE with Administrative Privileges.

    Step 3 :
    Run the following command Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:E:\sources\sxs /LimitAccess, and hit Enter.

    After completing the installation of .NET Framework 3.5 you can see that the feature is enabled.


    Although it is win8 solution, it also works for win10.

    Reference link:
    https://support.microsoft.com/en-us/kb/2785188

    Best Regards,

    Wen Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Tuesday, December 1, 2015 9:57 AM
    Moderator
  • Thanks Dear Lana XU,

    sorry to say still i am getting all above errors again

    Error 6 To enable 'Download prerequisites from the same location as my application' in the Prerequisites dialog box, you must download file 'DotNetFX35SP1\dotNetMSP\x86\NetFX2.0-KB948609-v6001-x86.msu' for item '.NET Framework 3.5 SP1' to your local machine. For more information, see http://go.microsoft.com/fwlink/?LinkId=239883. KingsPUMP

     and rest all above errors  again

    Windows Program And Feature Screen On My Windows 10  laptop

    Tuesday, December 1, 2015 4:32 PM
  • Sorry Experts,

    after removing from prerequisites to install list 

    .net frame work 2.0 (x86) 

    .net frame work 3.0 (x86) 

    .net frame work 3.5 

    Windows Installer 3.5

    which all were shown in Yellow Exclamation alert ( prerequisites could not be found in boot strap)

    the publish is successful but i yet have to test  at client place



    Thursday, December 3, 2015 6:18 AM