none
Visual Studio debug break mode slow to show resuls

    General discussion

  • Hi all,

    Recently (past month or so) I have stumbled upon a nerve breaking issue. Before i can describe the issue I would state all the tools I am using.

    I am working on:

    • Windows 10 Enterprise build 1511 OS 10586.218
    • Visual Studio Enterprise 2015 version 14.0.25123.00 Update 2
    • IIS version 10.0.10586.0
    • MVC 5
    • Framework 4.5.2
    • Running by web mvc application on  Local IIS(NOT USING IIS EXPRESS!!!)

    My Problem:

    While i put a break-point in any location and go to see the results of an object, there is a big delay to show these results(popup debugging context menu) while hovering over with the mouse on a object.A delay more than 10 seconds . This is unacceptable because it delays the whole debugging process.

    As I stated before I am running the mvc application on Local IIS. I even tried this in a brand new empty mvc application and the same thing happens. THE WEIRD thing is when i run the mvc application on IIS express the problem is fixed. Also as I said this problem never existed before with exactly the same setup. Just appeared out of nowhere. Also I saw this happen with some other users in my team.

    Does anybody know anything or have the same issue? Why does this delay occurs when running the MVC web application on Local IIS? 

    The problem that i have encountered recently, these settings where always the same from the start and the problem never existed before but showed up out of the blue. Maybe some windows update or visual studio update (problem existed even before Update 2). 

    Thank you for your time and hope somebody can help out!


    • Edited by TheoViva Thursday, April 28, 2016 6:51 AM
    • Changed type TheoViva Monday, May 23, 2016 7:46 AM
    Wednesday, April 27, 2016 12:45 PM

All replies

  • Hi TheoViva,

    (1)Not debug your app, just run it using "start without debugging", how about the result?

    (2) During debug your app, whether it also opened other windows during the Editor code window? Like the Diagnostic tool or others. Maybe you could disable it under TOOLS->Options->Debugging.

    (3) As far as I know, it will spend several seconds loading the symbols, or it will spend much more time when load them for the first time, so if possible, disable the Microsoft symbols server under TOOLS->Options->Debugging->Symbols, debug your app again.

    (4) Not a solution, to make sure that it is not the project file issue, just create a new blank solution, and then add the project files to the new blank solution, clean and rebuild, debug it again.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, April 28, 2016 9:07 AM
    Moderator
  • Hi Jack, Thanks for the reply. Just to clarify. My problem is the datatips. That means when i press that arrow to show the object results while in break mode the objects results delay to show up. Also i tried an empty mvc application and same thing. Also I tried loading symbols locally and again the same thing. Its a weird issue. Again to clarify its while in break mode at the popup context box that shows the object result after pressing that small arrow when hovering over with the mouse. 15 sec delay is not logic and it happens all the time on all object and also in a completely  new default project. I will add a photo once verified.
    Wednesday, May 4, 2016 10:43 AM
  • Hi  TheoViva,

    Thanks for your friendly response.

    >>The problem that i have encountered recently, these settings where always the same from the start and the problem never existed before but showed up out of the blue. Maybe some windows update or visual studio update (problem existed even before Update 2). 

    (1)So it didn't have this issue before, if so, maybe you could run your VS in safe mode or as the admin, debug it again.

    Devenv.exe /SafeMode

    At least, we could know that whether it is related to certain add-ins or extension tool.

    (2)Of course, please also close all third party tools/processes in your windows, and make sure that the task manager is free.

    (3) Delete the .suo file in this project folder, and then re-open .xxproj file, debug it again.

    If still no help, one idea is that you could share us a simple sample using one drive, I will download and test it in my side using the same Environment as yours. Please also share us a screen shot about the result in your side, so we could compare our result with yours.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 5, 2016 6:06 AM
    Moderator
  • Hi Jack,

    For No. 1:

    Safe mode was tested also with the problem still doing the same thing.

    For No. 3:

    As I stated I have tried this on a completely new project so the suo or xxproj file in not related. But just to be sure i did it and same thing exists. Also was tried on other users with other systems and again the same issue(problem existed on same project but also on completely new mvc web application).

    For No. 2:

    Restarted pc in safe mode and tried running the project and in normal mode closing all unnecessary things and again same thing.

    Just to state what i think the problem is : I run the project in IISLocal. If i run it in IISExpress it works ok. something is wrong maybe with the iis. its weird to work ok on express and not on iis local. Maybe microsoft had done a update on it.



    • Edited by TheoViva Thursday, May 5, 2016 7:54 AM
    Thursday, May 5, 2016 7:52 AM
  • Hi TheoViva,

    Thanks for your response.

    What I know that certain settings in VS IDE or the temp files would impact the debugging performance.

    For example:

    VS menu Tools -> Options -> IntelliTrace, uncheck the checkbox for "Enable IntelliTrace".

    Or we could deleted the "Temporary ASP.NET Files" folder in our windows. 

    But as you said that it just has this issue using IIS Local, maybe you could discuss this issue with IIS members, you know that it has his own supported site.

    https://forums.iis.net/

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, May 6, 2016 7:42 AM
    Moderator
  • Thanks alot. I will try over there too. Tried also the above two things and same things again sadly :(

    Monday, May 9, 2016 8:47 AM
  • You are welcome, TheoViva.

    Since you will post this issue to the more appropriate IIS forum, would you mind changing the issue type to General Discussion? So I could open this case for you, and other community members could also share the experiences here.

    You could change the issue type by opening the Options list at the top of the post editor window, and changing the type. 

    Of course, if you get any useful information from the IIS forum, please feel free to share it here.

    Have a nice day,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, May 10, 2016 5:45 AM
    Moderator
  • Ok done! :) Would glad to type any helpful info i find but just for ref. the iis post is in the below link but with no luck sadly :

    IIS issue post


    • Edited by TheoViva Monday, May 23, 2016 7:49 AM
    Monday, May 23, 2016 7:48 AM
  • In the IIS the application pool advanced settings two properties were changed  : Start Mode set to "Always Running" and Enable 32-Bit Applications set to "True".


    This fixed the delay big time but ok some small delay still exist.

    Monday, June 6, 2016 7:34 AM