locked
Can't access to the central administration sharepoint 2013 error day time RRS feed

  • Question

  • Hello everyone,

    here is my problem. I can't access to the Central administration sharepoint 2013.

    And i don't know why. heres the error. when i try to display the central administration  i have an sorry something went wrong.

    with id correlation i tried to figure out the problem. here's the log events i have.

    File reader could not understand line 0. Line was: 10/28/2015 10:13:42.10 w3wp.exe (SPSPAPP:0x4D20)               0x2C94 SharePoint Foundation         Logging Correlation Data       xmnv Medium Name=Request (GET:http://spspapp:2013/default.aspx) 64fe3b9d-c65d-7054-affb-e4d7abda9096. Error was: System.FormatException: La chaîne n'a pas été reconnue en tant que DateTime valide.
       à System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles)
       à UlsGump.Column.TimeColumn.ParseTime(StringFacade timeString)
       à UlsGump.UlsEntry.SetEntryFromThread(StringFacade[] threadFacades, StringCacheFile stringCacheFile, Int64 messageLocation)
       à UlsGump.UlsEntry.ReadFromUlsBuffer(Char[] buffer, Int32 bufferStart, Int32 bufferCount, StringCacheFile stringCacheFile, Int64 fileStart)
       à UlsGump.FilePump.ReadJob()

    It's clear to me that maybe it's an error of daytime but i don't know how to correct it. I have to inform you that i'm from France and the day is display like this. DD:MM:YYYY the problem here it's that sharepoint by some sort of magic set himself on american day time MM/DD/YYYY and i don't know how to fix it.

    thanks for all te help you can give me. And sorry for the bad english too. :-)


    • Edited by IT_AL_PARIS Wednesday, December 2, 2015 4:20 PM
    Wednesday, October 28, 2015 10:42 AM

Answers

  • Hello guys,

    I found the solution.

    the web.config of the central administration had some errors.

    I compare the backup of the web.config with the new one and the errors where made by another person.

    And now i restored the web.config and it works like a charm

    Thanks everyone

    • Marked as answer by IT_AL_PARIS Wednesday, December 2, 2015 4:20 PM
    Wednesday, December 2, 2015 4:19 PM

All replies

  • Hi there

    are you able to access your central admin like below:

    http://<central_admin_site_url/_layouts/settings.aspx

    if this works for you change the regional settings for site

    Site Administration --> Regional settings

    • Proposed as answer by Taifour Wednesday, October 28, 2015 11:06 AM
    • Unproposed as answer by Taifour Sunday, November 1, 2015 8:46 AM
    Wednesday, October 28, 2015 11:04 AM
  • It doesn't work, i can't access to the settings.

    i have the same problem :sorry something went wrong.

    but thanks for your fast anwser :-)

    Wednesday, October 28, 2015 12:26 PM
    • Proposed as answer by Sachin Choube Wednesday, October 28, 2015 1:24 PM
    Wednesday, October 28, 2015 1:24 PM
  • were OS regional settings changed recently? If yes try to change them back, make iisreset and restart Sharepoint Timer service.


    Blog - http://sadomovalex.blogspot.com
    Dynamic CAML queries via C# - http://camlex.codeplex.com

    Wednesday, October 28, 2015 1:47 PM
  • same problem it doesn't work 
    Thursday, October 29, 2015 12:35 PM
  • Hello already try that also y try to change settings on iIS but the change on globalisation.net doesn't give much result either

    Friday, October 30, 2015 3:32 PM
  • try to access the URL directly 

    http://<siteURL>/_layouts/regionalsetng.aspx or http://<siteURL>/_layouts/15/regionalsetng.aspx

    if this didn't work reset lets try using PowerShell

    try do it on UAT first before going direct to Prod

    reset your Regional settings, use the below script 

    #Get Web Application
    $webApp = Get-SPWebApplication "http://<siteURL>"
    #$Reset Web Application's default timezone
    $webApp.DefaultTimeZone=-1
    $webApp.Update()

    then if want to continue using PowerShell to change your RS to french use the below command:

    Add-PSSnapin Microsoft.SharePoint.PowerShell -ErrorAction SilentlyContinue

    #Site URL variable
    $SiteUrl ="http://intranet.crescent.com"

    #Get site object
    $web = Get-SPWeb $siteUrl

    #Set Locale setting
    $culture=[System.Globalization.CultureInfo]::CreateSpecificCulture("en-US")
    $web.Locale=$culture

    #Set Timezone
    $TimezoneID = 23 #(GMT+05:30) Chennai, Kolkata, Mumbai, New Delhi
    $web.RegionalSettings.TimeZone.ID = $TimezoneID

    #$web.RegionalSettings.Time24=$True
    #$web.RegionalSettings.FirstDayOfWeek=1 #Sunday

    #Update settings
    $web.Update()

    Refer this MDSN link to get IDs for timezone: https://msdn.microsoft.com/en-us/library/office/jj247008.aspx?f=255&MSPPError=-2147217396

    Thanks.

    • Proposed as answer by Taifour Tuesday, November 3, 2015 11:12 AM
    Sunday, November 1, 2015 9:02 AM
  • Any Luck with the provided solution ?

    Thanks

    Tuesday, November 3, 2015 7:02 AM
  • I'm sorry for the my late answer.

    i try the 2 url but witthout success.

    I have to admit that i failed to  do the powershelle part.

    But something come to my mind. In the logs the time it's fine and the date it's fine it just the format date time that sharepoint can't handle.

    File reader could not understand line 219. Line was: 11/24/2015 13:54:03.92 w3wp.exe (SPSPAPP:0x3BD4)               0x3548 SharePoint Foundation         Database                       8acb High [Forced due to logging gap, Original Level: VerboseEx] Reverting to process identity bbbb449d-f62c-7054-affb-ee31333dbc3e. Error was: System.FormatException: La chaîne n'a pas été reconnue en tant que DateTime valide.
       à System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles)
       à UlsGump.Column.TimeColumn.ParseTime(StringFacade timeString)
       à UlsGump.UlsEntry.SetEntryFromThread(StringFacade[] threadFacades, StringCacheFile stringCacheFile, Int64 messageLocation)
       à UlsGump.UlsEntry.ReadFromUlsBuffer(Char[] buffer, Int32 bufferStart, Int32 bufferCount, StringCacheFile stringCacheFile, Int64 fileStart)
       à UlsGump.FilePump.ReadJob()

    the bold line  says "the chain wasn't recognize as valid datetime" I don't know how to set the date time like in europe dd/mm/yyyy instead of mm/dd/yyyy

    Also i already check the date time on the windows server and it's on the european format.

    I have 3 servers 2 for sharepoint and one for the database, and all of them have the right format on windows server 2008r2.

     


    • Edited by IT_AL_PARIS Tuesday, November 24, 2015 5:09 PM
    Tuesday, November 24, 2015 2:04 PM
  • Some news for you guys, I still have my problem but i have found another path to follow for the resolution of this problem

    https://social.technet.microsoft.com/Forums/office/en-US/02dca2f0-1963-4915-b933-d0d515042c33/cannot-access-central-administration-web-application-file-not-found-error-after-i-remove-a-web?forum=sharepointadmin

    Long story short this thread tells you how make sharepoint errors more talkative.

    I tried this solution to know bettter the problem and here's the result.

    Now I have this error when i tried to reach the central administration of sharepoint.

    Erreur du serveur dans l'application '/'.

    Le DataSourceID de 'V4QuickLaunchMenu' doit être l'ID d'un contrôle de type IHierarchicalDataSource. Un contrôle avec l'ID 'QuickLaunchSiteMap' est introuvable.

    Description : Une exception non gérée s'est produite au moment de l'exécution de la requête Web actuelle. Contrôlez la trace de la pile pour plus d'informations sur l'erreur et son origine dans le code.

    Détails de l'exception: System.Web.HttpException: Le DataSourceID de 'V4QuickLaunchMenu' doit être l'ID d'un contrôle de type IHierarchicalDataSource. Un contrôle avec l'ID 'QuickLaunchSiteMap' est introuvable.

    Erreur source:
    Une exception non gérée s'est produite lors de l'exécution de la requête Web actuelle. Les informations relatives à l'origine et l'emplacement de l'exception peuvent être identifiées en utilisant la trace de la pile d'exception ci-dessous.

    Trace de la pile:
    [HttpException (0x80004005): Le DataSourceID de 'V4QuickLaunchMenu' doit être l'ID d'un contrôle de type IHierarchicalDataSource. Un contrôle avec l'ID 'QuickLaunchSiteMap' est introuvable.]
       System.Web.UI.WebControls.HierarchicalDataBoundControl.GetDataSource() +412
       System.Web.UI.WebControls.HierarchicalDataBoundControl.ConnectToHierarchicalDataSource() +215
       System.Web.UI.WebControls.HierarchicalDataBoundControl.OnLoad(EventArgs e) +28
       System.Web.UI.Control.LoadRecursive() +95
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Control.LoadRecursive() +190
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2936
    


    Informations sur la version : Version Microsoft .NET Framework :4.0.30319; Version ASP.NET :4.0.30319.34249 

    i think the most interesting part is this one 

    QuickLaunchSiteMap' est introuvable.] it says it can't found quicklaunchsitemap.

    Maybe this error could talk to any of you.



    Tuesday, December 1, 2015 8:36 AM
  • Hello guys,

    I found the solution.

    the web.config of the central administration had some errors.

    I compare the backup of the web.config with the new one and the errors where made by another person.

    And now i restored the web.config and it works like a charm

    Thanks everyone

    • Marked as answer by IT_AL_PARIS Wednesday, December 2, 2015 4:20 PM
    Wednesday, December 2, 2015 4:19 PM