none
820 EDI validation RRS feed

  • Question

  • BizTalk will only accept an 820 with country code (N404) other than US or USA.  Does anyone know how to configure BizTalk to accept these files.  I have tried turning off EDI validation on the party and the receive location.  I am told that my bank cannot change this because they do not create the 820’s they just forward on to us what is sent to them.

     

    Fails:

    N4*PHILADELPHIA*PA*19102*USA~

    N4*PHILADELPHIA*PA*19102*US~

     

    Works:

    N4*PHILADELPHIA*PA*19102~

    N4*PHILADELPHIA*PA*19102*CA~

    N4*PHILADELPHIA*PA*19102*ZZ~

    N4*PHILADELPHIA*PA*19102*ZZZ~ 


    Thanks in advance

    Thursday, January 14, 2010 10:17 PM

Answers

  • Uncheck "Use ISA11 as repetition Separator" in the party's EDI interchange as sender settings.

    • Marked as answer by ParahT Friday, January 15, 2010 8:17 PM
    Friday, January 15, 2010 8:17 PM

All replies

  • Can you add USA and US to the enumeration of acceptable values for N404 in your custom 820 schema?

    Thanks,
    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Friday, January 15, 2010 6:33 PM
    Moderator
  • Uncheck "Use ISA11 as repetition Separator" in the party's EDI interchange as sender settings.

    • Marked as answer by ParahT Friday, January 15, 2010 8:17 PM
    Friday, January 15, 2010 8:17 PM