locked
SharePoint 2007 prompting for second login when opening Office Documents RRS feed

  • Question

  • The second login is not prompted for when opening PDF files but always occurs when opening Word documents, the SharePoint site is added to the local Intranet zone and the setting is configured in IE to "automatic logon with current username and password". Clients are XP SP3 with a mix of IE6 and IE7 the reg entry has been set on clients to  AuthForwardServerList with FQDN of SharePoint Server under:

    HKLM\System\CurrentControlSet\Services\WebClient\Parameters

    In addition in Office 2003 which is used on all clients the shared workspace option is disabled, all this has been done but sadly all clients are still prompted for authentication any help wuld be great as this is causing the users constant issues.


    Carl Smith MCITP-EA
    Monday, June 14, 2010 9:34 AM

Answers

All replies

  • This looks to me a network problem. Have you checked that the proxie(s) are forwarding auth?

    Is there a chain with two different proxies?

    You could also see if it occurs from a test client manually adding the WFE IP to the host file.

    Monday, June 14, 2010 11:01 AM
  • There is no proxy involved here the XPSP3 clients connect direct to the SharePoint site, PDF files open fine without the second authentication however it is just Office files that prompt.  If I cancel the authentication prompt when opening the Office document it does open but the authentication box will keep appearing all the time.  Is there a way to disable such a feature from occuring in Office with regards to connecting to SharePoint?
    Carl Smith MCITP-EA
    Monday, June 14, 2010 11:06 AM
  • oops misclicked and lost the post...

    Basically, i was saying your can turn off the feature by turning off "client integration" in the auth provider (app settings).

    Else, as per  http://support.microsoft.com/kb/2019105/en-us

    In order to establish the richest experience possible, the first thing Office will do is communicate with the server to determine the server type and what type of Web authoring protocol is available. It does this by making an OPTIONS request.

    You can either block those verbs, or try the methods offered in that KB, which looks the heart of your problem :)

    Edit : also, be sure to check if the documents open in the browser itself or the office client, as this hasn't the same behavior.

    Monday, June 14, 2010 11:38 AM
  • Both propose as answers unproposed.

    Please do not propose your own answers, it's not helpful.

    Propose the good answers (!) of other people. Wait until someone else proposes your posts.

    (Moderator)


    2010 Books: SPF 2010; SPS 2010; SPD 2010; InfoPath 2010; Workflow etc.
    2007 Books: WSS 3.0; MOSS 2007; SPD 2007; InfoPath 2007; PerformancePoint; SSRS; Workflow
    Both lists also include books in French; German; Spanish with even more languages in the 2007 list.
    Monday, June 14, 2010 12:19 PM
  • Managed to fix the issue by following the instructions in the link:

    http://mysharepointblog.com/post/2007/02/Suppress-Microsoft-Office-Document-Authentication-Prompt-In-SharePoint-WSS-30.aspx

    It involved hacking the CORE.JS file this was the only fix I could find!


    Carl Smith MCITP-EA
    • Marked as answer by Lily Wu Wednesday, June 16, 2010 1:43 AM
    Tuesday, June 15, 2010 8:08 AM