locked
Show user names in survey results? not displaying RRS feed

  • Question

  • Hi all,

    i have created a Quiz by using survey webpart,

    but the problem is when user responds to the survey, the name of the user is not displaying on the show all responses page, can someone help me?

    In Survey Options  i have selected "Show user names in survey results? "
    but still when exporting to spreadsheet im not able to see the names of who has responded to the survey

    im using sharepoint foundation 2013

    it's urgent please.

    Monday, December 9, 2013 12:52 PM

Answers

  • Hi,

    According to your description, my understanding is that the user names were not displayed in the Survey list.

    I recommend to verify the things below:

    1. Check the permission settings of the Survey list to see if the Survey list is set to allow anonymous users to respond to the survey. If yes, the name will be blank when anonymous users to respond to the survey.
    2. Can your account see the responses created by others but only cannot see the names?  Were the names blank or replaced with ***?
    3. Did this issue occur with other Survey lists? Create a new Survey list to see if the issue still occurs.
    4. Was there any customization on the Survey list?

    Best regards.

    Thanks

    Victoria Xia
    TechNet Community Support

    • Marked as answer by JasonGuo Saturday, December 21, 2013 4:09 AM
    Wednesday, December 11, 2013 10:18 AM
  • Go to the other survey result list data and export in Excel,You can get data acording your requirement.

    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    • Proposed as answer by Hasan Jamal Siddiqui Wednesday, December 11, 2013 10:55 AM
    • Marked as answer by JasonGuo Saturday, December 21, 2013 4:09 AM
    Wednesday, December 11, 2013 10:55 AM

All replies

  • Hi,

    According to your description, my understanding is that the user names were not displayed in the Survey list.

    I recommend to verify the things below:

    1. Check the permission settings of the Survey list to see if the Survey list is set to allow anonymous users to respond to the survey. If yes, the name will be blank when anonymous users to respond to the survey.
    2. Can your account see the responses created by others but only cannot see the names?  Were the names blank or replaced with ***?
    3. Did this issue occur with other Survey lists? Create a new Survey list to see if the issue still occurs.
    4. Was there any customization on the Survey list?

    Best regards.

    Thanks

    Victoria Xia
    TechNet Community Support

    • Marked as answer by JasonGuo Saturday, December 21, 2013 4:09 AM
    Wednesday, December 11, 2013 10:18 AM
  • In the Survey list where all results are stored add the Display Name column, when you go to export the list data to excel it will show with the user's name
    Wednesday, December 11, 2013 10:21 AM
  • Go to the other survey result list data and export in Excel,You can get data acording your requirement.

    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    • Proposed as answer by Hasan Jamal Siddiqui Wednesday, December 11, 2013 10:55 AM
    • Marked as answer by JasonGuo Saturday, December 21, 2013 4:09 AM
    Wednesday, December 11, 2013 10:55 AM
  • If you want to show the identity of the user who responded your survey, just perform the following steps:

    1. Navigate to your survey page
    2. Click Settings and then click Survey Settings

      survey-settings

    3. Under General Settings click Title, description and navigation link

      general-settings

    4. Under Survey Options, select No for the question Show user names in survey results?

      show-user-names

    5. Click Save

    Now, check your survey and you will see that all user identity fields like Created By and Last Modified By will just show *** instead of the original user name.


    Hasan Jamal Siddiqui(MCTS,MCPD,ITIL@V3),Sharepoint and EPM Consultant,TCS

    Thursday, December 12, 2013 5:40 AM